1.5KW upgrade

So I bit the bullet and did an upgrade to the 1.5KW water cooled spindle.

I love it, so quiet. What I didnt love was setting it up.

So, for reference here is what I have:

  1. Water Cooled 1.5KW Spindle, and associated VFD
  2. Water going thru a radiator and peltier cooler (Because I am wierd like that)
  3. All lines routed through drag chain

I got the spindle running fine, here is the issue:
When attempting to actually route, it starts and does maybe one xy line of the route, then stops.

Here is what I believe the issue is:
I am using the stock stepper cables, and they arent properly shielded

So I ordered shielded cables.

Anyone concur with my analysis?

Interesting. Would love to see pics of your new setup

As for what’s killing it … does it die if you do an air carve with the router off? Or same issue?

Ill take some pics when I get it back together.

No, the spindle continues to spin, but the stepper stop functioning and nothing really hapens in easel to tell me I had a failure.

Also, I am putting together a BOM, and the various carve and 3d print files to replicate my cooling box.

If you run a job with the spindle totally off (fake the material height with a removable block) does the job still die the same way?

I didnt try that before my rebuild, but I did jog manually for quite a while without the spindle running and it never failed.

Then if I turned the spindle on and jogged it would fail within 1-3 moves.

That being said, I had a job I HAD to do (For my son’s cub scout troop) so I disassembled everything and put the dewalt back on for the time being.

Was your DeWalt’s cable in the drag chain?


I made DIY controller way back, using Arduino and TB6560’s.
It would jog fine all day long but when I started a carve it would abort as soon as it started moving. (router started prior to hitting Carve).
I solved it by providing the Arduino with a separate 12V PSU.

A VFD inverter can be quite noisy EMF/RF-wize. Especially ebay items. Speaking of ebay spindles, most have 4-pin wire layout but the grounding pin is usually actually not connected to spindle ground.

Yes, mine is sadly not grounded.

They are both on separate power supplies, as one is on a VFD and the steppers are controlled by the X-Controller.

When I rebuild Ill ground the spindle as well.

Yes, but its standard 110, not VFD

Does the VFD have a shielded cable?
Is it grounded?

Yes VFD cable is shielded and I connected it to the ground on the VFD.

What size peltier are you using?


I’ll bet a nickel that the spindle is messing with the limit switches.

1 Like

That is an excellent point Dan. When I finish this pressing job (Plaques for my Sons Arrow of Light Ceremony), and I rewire. I will also rewire the limit switches with shielded cable.

I had this exact problem when I threw a 1.5kw spindle on mine. the limit switches just went dead

Good to know, I am going to rewire them with shielded cable when I redo it all

I used cat 6 stranded wire and used one wire in the twisted pair for grounding and the other for connection. worked like a charm. I ground only one end. I grounded to the box not the machine.

Ok, redid everything and it still does it. But not as frequently. It also does it with the limit switches not plugged in.

So I bought some better shielded cable for the power for the spindle.

It only does it with the spindle engaged, so process of elimination that has to be it. Will reply with the results.