1st start up - Y axis no movement issue in machine setup

Searched for this in the forum but cant find my particular issue.
Doing the 1st machine setup and X and Z axis are working fine but Y is no go.

Here is my wiring.

In addition Z and X I can tun by hand and the green lights work on the PCB but Y is now hard to move by hand like the wires are crossed but I see no error in the wiring.

Anb help appreciated


With the power supply off, does the gantry move back and forth smoothly without binding?

No it is grabbing

I would fix that first. Probably the V-wheel adjustment.

Oh that yes I adjusted the wheels correctly its not the wheels binding

I don’t see an issue with your wiring. The Y axis current limit setting looks to be a little high, turn it back to match the others until we get things working.

I believe so I posted my wiring in the top post

Which stepper motors do you have, 17s or 23s?

I think the wiring is correct.


I’ve been looking at that current limit pot and I can’t tell if the setting is high or zero. Check to see if it is turned all the way down, but be careful it is easy to damage the pot by turning it too hard. When you are finished testing its motion make it match the other two.

Ok giving it a try

lol, understand, I did just try and disconnect the wires on one side and still no go

1 Like

Ok, try this. Switch the wires at the gShield for the X and Y axis.

Put X axis on Y gShield
Put Y axis on X gShield

See which axis doesn’t work.

I tried lowering the potentiometers in all axis, X is as low as it can go, z is likewise, (I can tell by the noise it makes when lowering the pot) but Y is nothing no matter how low. I did not go very high

I will give it a try

For that test make sure that all the pots are back in the positions that the X and Z were in the picture, so that if you took a new picture Y would look different but X and Z would be the same.


OK LarryM

Switched wires at the gShield for the X and Y axis.

Put X axis on Y gShield
Put Y axis on X gShield

X works and Y axis doesn’t work.

So, that says that the gShield x axis driver is working and the Y axis driver is working.

Put things back the way they should be on the gShield.

It does look like a Y axis issue.

Which Y motor did you disconnect for the one motor on the Y axis test?