Inventables Community Forum

3018 CNC List of Issues

I have been trying at this for probably about 6 hours now at this point and am at my wits end, so this post will probably serve as both a way of venting and hopefully getting a solution. I got my 3018 awhile back and after resolving a few issues with the seller (faulty power supply), I was able to at least get things working on an old laptop I planned to run it on. By running I mean it moved with the jog controls and the spindle turned on and off, but I never got around to actually making anything.

As of late I finally decided to make a relatively simple engraving to go on a coaster. (The design itself is silly and was meant to serve as a joke gift)
Brightavec_svg

Problems:
Old Computer - I made the design on the Carbide Create and went to run the code on Candle. After clicking send, it did well, nothing. The status of the CNC was shown as “hold”, I was not able to find any information on this. Some of the commands are processed and sent but after just a few lines the rest remain queued. I then exported the gcode and imported it into Easel. When trying to run this code the machine would instead just decide to ram its self into the bed, I honestly couldn’t tell if it was trying to do a homing maneuver or what it was doing, but I know I had homing switches disabled (Also important to note it was moving in the opposite direction it should move if it was actually starting the cut so I don’t think its a size/scale issue). I then decided I should recreate the cut in easel and let it generate its own gcode. After importing the svg and setting all the appropriate settings for the cut and finally hitting carve, it well, got stuck simulating the toolpath.

New Computer - With the failures of the old computer, I figured I would try a newer computer and maybe that would solve my issues, instead it came with its own list of different issues. When trying to work with Candle the spindle worked just fine, however the jog commands were completely useless. This was interesting because once I switched to Easel all movements suddenly functioned as usual. I suspect this comes down to a driver issue conflicting with the newer computer but I honestly have no clue. I’m pretty sure the drivers install to the CNC itself, not the computer, but I guess interactions could still vary, though the drivers installed without issues. Just for the heck of it, even though it couldn’t move I tried sending the gcode on Candle and it acted similar to the old computer, instead its status was “unknown”. I then switched back to Easel, I figured the old computer had trouble simulating the toolpath due to its inferior processing power however this newer one failed in the same way.

I’ve tried looking around countless Youtube videos and forums searching for answers and have found many similar issues, however not quite matching up with the specific ones I face (I still tried many of given solutions to similar problems but saw little success). Lastly, I still need to check if there could be issues with this designs complexity, possibly leading to the toolpath simulation getting stuck even though I don’t really see how this design could be too complex given the numerous more complex designs I have seen others accomplish (Though it could be horribly unoptimized?) and try to run example files from the various computers (Yes I know, probably should have done that first…). That being said I could totally be wrong and am a complete beginner and I am sure and hopeful that there have been obvious solutions that I have missed.

Thank you if you have made it this far, Michael

My suggestion would be to download the stable version of Universal Gcode Sender or UGS and try that out. I also would suggest a more generic post processor in case some of your gcodes are not supported by GRBL. Fanuc or Maxnc are the ones I use. I haven’t heard much positive stuff here about Candle.

Download - UGS (winder.github.io)