3018 Pro fro Vevor

Hi all, i am new to CNC’s. My problem is that when i go to carve anything it all turns out backwards and upside down. I have checked the polarity, made sure all the wiring to the board for the X, Y, Z axis’s are plugged in correctly. It doesnt mater whether i use candle or Easel. Even reversing pictures when using the laser in LaserGRBL

1 Like

Hey and welcome!.

The easy method to fix the issue is within Easel go to machine>edit machine and delete the profile, and then go to machine>setup new machine…
The first step in the setup after easel connects it asks you to test the direcrions. Verify the left button moves left, right =right. Up=up and down=down. . . .HOWEVER on the 3018 since the bed moves the forwars button needs to move the bed back and the back button needs to move the bed forward.

This is because as the bed moves back the position of the spindle becomes closer to the front of the workpiece (forward)

There is also a method to fix it by manually setting the grbl setting $3 which is the directional control, however this is actually what easel does for you based on your answers to the direction test :+1:

Hi Seth, sorry for taking so long to get back to you, I have just gotten home as i work away all week, I will try your suggestion which absolutely makes sense. I appreciate you getting back to me and will let you know if this works, its been doing my head in for weeks :crossed_fingers:
Regards Shane Azzopardi

1 Like

Hi Seth, you are a legend, i did what you said with setting and it work perfectly. :+1:
I really appreciate your help, now just have to wait till next weekend to get some projects started,
Regards Shane Azzopardi

1 Like