3018 z axis under delivering

I’ve recently done an 18mm mdf cut-out which worked beautifully, today trying to do a 12mm one and I’m only getting a cut to around 4mm. I’ve now noticed that jogging doesn’t deliver the movement specified in jog function ie 0.1, 1.0 or 10mm I’m only getting a fraction. The z screw seems free when turned manually and there doesn’t appear to be any bind when driven from jog function. Could this be a stepper motor or calibration issue. I noticed Easel seems to have been upgraded is there a known issue?
Thanks for any help on this one.

Most likely either step/mm OR driver microstep issue. (Issue as in not matched jog command vs actual command)

Recalibrate the step/mm value ($102 GRBL parameter for Z)

Hi Bob and Haldor.

I had an almost similar problem where my z axis went Haywire. My xy multiplied in movement almost ten times. I tried re calibrating in UGS but things were still malfunctioning. I then uninstalled my Arbuino IDE and re installed afresh installation. I then cleared out my Arduino Uno board and did a fresh GRBL Sketch and re flashed the board. I the re calibrated my Machine. Everything works fine now. I would suggest a fresh installation and Flash.

Hi both, and thanks for your replies, i’m a newbie so how do I calibrate “Z”, do I need to know leadscrew pitch?

If you have UGS installed on your PC it will be very simple. In UGS you can open the installation wizard and follow the steps. set a zero point jog your z 20mm. Measure actual movement. open wizard and go to calibration window. it will show your movement you typed in and also have a place to type in your actual movement. after typing in actual movement it will show your actual steps. type in actual steps click update. Your Z axis is now calibrated. no difficult calculation needed. This action will automatically update $102 parameter for Z Axis.

1 Like

Thanks very much for the explanation, sounds straight forward, but then as I’m a newbie…

Hi Bob

Firstly, make sure you have a metric square or some way to measure with millimeters :triangular_ruler:

Drop your Z as low as it can (or raise as high as possible). Measure how many millimeters it is from the bottom (or top). Make note of that #.

Jog the machine a set amount, say 100mm.

Re-measure to see how many mm it actually moved & take note.

Divide the desired 100 by the actual (say, 108)

Take that result (in this case 0.9259)
Open Easel → Machine → Machine Inspector → Advanced

Line $102 is your Z-axis. Multiply the value of $102 by the number you got from dividing (in this case 0.9259). Put that new # value in by typing $102=new value.

Keep repeating this process until when you jog that machine 100 (or more, more = more accuracy) and it actually moves the same exact amount.

Best wishes.


Thanks Josh,
Thank goodness for forum users - such prompt and helpful replies.

1 Like

All sorted now, performing well, thanks very much for your help chaps.

Like others have said, these great responses are invaluable. Somehow my $102 was 320 and should have been 800. Off by factor of 2.5 which is what I had already determined by measurement. Until I found this info I was forced to use calculator to determine every depth and was always anxious about it reverting to the actual input which would drive bit through work and even spoilboard in some case. Again, thanks.

1 Like