3D Help = Generating G-Codes

OK, so I know that a 3D carve of The Last Supper is probably one of the most difficult carves to do…but an 8" x 12" of The Las Supper wouldn’t be very impressive.
So I ran the file through the “simplify” routine and got it down to under 100meg. I loaded into Easel & set a 1/4" roughing and a 1/16" Ballnose for my bits. I’m going to carve it on some 1-3/8" oak. I enlarged the carving to 29" x 13".
So, when I try to make G-code files (under the “Projects” pulldown), it doesn’t do a thing…it doesn’t make files, it doesn’t crash, nothing.

Any help would be appreciated.


a FYI your aspect ratio changed, maybe just a typo and it’s supposed to be 19.5"x13"?

Correct. After configuring your cut settings and all that, there’s a grey button at the bottom right “generate toolpaths” click that, let it generate. THEN you can run the carve OR Export the Gcode.
they kinda changed it up for 3d a little in this regard.
Hopefully doing this one step first works for you.
Merry Christmas

OK…for starters, the STL file I bought wasn’t exactly 8" x 12", but it was small, and I scaled it up maintaining the proper aspect ratio.
When I tried the “Generate Toolpaths” button, a window opened up that said “Generating toolpaths” with the little dots chasing each other. That lasted about 5 minutes, then I got the “Aw Snap” window. When clicked on it’s button, it just reloaded the project.
Any Ideas?
Merry Christmas to you also.

If you like, you can share the easel project by going to Project>Share then setting it to “unlisted” and copying the link shown, then DM me the link since you bought the file you probably don’t want to post it up here publicly…

The aw snap is usually a sign that the carve is complex and the gcode file size is larger than your browser can support. And or RAM is maxed out too.
Firefox uses RAM differently than other browsers so that one seems to be able to process larger 3d toolpaths better than chrome/ edge. And having a bunch if excess ram and processing speed helps too…

the Aw Snap message is often related to network timeout. With Firefox you can adjust network timeouts upwards to avoid this - but as Seth indicates this is usually a precursor to memory issues later…

1 Like

I guess I thought that the G-Code file was built on the Easel server, and not with the browser.
I installed Firefox & tried it. I didn’t get the “AW Snap” message, it just chewed on the file for a half hour before I canceled it.

Seth…I messaged you the link

1 Like

It does everything other than save the project, load a saved project, access font directory, access the apps, access the design library all on the users PC, so I could load Easel and immediately put my PC in airplane mode, i could still do some degree of design using the fonts that are already loaded up, and use the shapes and all of the other standard tools/functions and then simulate the toolpath and carve all offline, . .
I’ve actually tried it on camera before to prove a point to someone who thought a faulty internet was why their carve was stopping (it was actually more likely the USB selective suspend setting OR static discharge from shop vac hose)

This is in the Xcarve Pro FAQ, but it applies to Easel across the board…

OK…well, I installed Firefox & tried…I never got the Aw Snap message…it just sat there with the spinning dots all night long.
I’m doing this on a Dell with a 2Ghz cpu & 12G of RAM. At this point I think I’m going to look for a different Last Supper file & see if I have better luck.
I’ve also got Fusion360 loaded, so I’m going to try to figure that out.

1 Like

Here’s how to 3d relief carve using an STL in Fusion360:
(My first video ever & still the 2nd most viewed :smiley: )

Thanks for the video…sorry I haven’t had a chance to try it yet.
Question: I saw in another post that it could be the “Settings” keeping the the G-Code from being generates. Which settings are are you referring to?

things like the size and z position placing the model above the material. too small of a bit and too small of an overall finishing stepover could generate a file too large for the browser to handle…
I’d really have to see the Easel Project to verify the settings there aren’t causing the toolpath to fail to calculate…

I thought I messaged you the file, but thanks for the info.
I bought another version of the file from a different vendor. It was under 100mb, so I didn’t have to run it through the mesh simplification routine.
I ran Easel in Firefox and the file STL loaded fine. I enlarged to design to 29" x 16" and clicked “generating toolpaths”. It took about 10 minutes, but created both files.
I’ll repost after I try cutting them,