3D Preview Isn't Showing

When I start Easel, I see a black area momentarily then it disappears and there is no preview. This is happening on my Toshiba laptop with Win7 and Firefox.

Do you have WebGL enabled?

It’s supposed to be enabled in Firefox from what I see. How do I check?

I checked Firefox and it shows WebGL enabled. I just checked and the 3D preview is showing in Chrome on this laptop. I’ll check more on the Firefox setup.

Is it the same laptop?

Try this:

  1. turn off WebGL close the browser
  2. Open the browser, load easel what do you see?
  3. Now enable WebGL and refresh what do you see?
  4. Try opening in Chrome and Firefox see if there is a difference.

I’m trying to figure out if it is a browser issue or a video card issue.

Zach, it has to be a Firefox issue. If I wasn’t clear in my last post, Easel works fine in Chrome on the same laptop where it doesn’t in Firefox. WebGL is enabled in Firefox and I also went into some “hidden” parameters and set WebGL to be forced to enable. I’ll dig into it a bit more when I have time. I use Firefox and Chrome interchangeably anyway.

Hey @BillArnold sorry about the trouble. I’ll start looking into Firefox to see if I can replicate. Browsers do change pretty frequently, especially with edge things like webgl. We try to keep up with changes as best we can (just finished some pretty major compatibility updates for IE in fact). But there aren’t any current known issues so I’ll start by trying to replicate.

Just tried it on a number of platforms, but I can’t replicate what you are seeing. I tried it on a windows 7 Acer and it worked without enabling anything, then tried it on my Mac through parallels and the GPU was blacklisted, but when I enabled the “hidden” flag it worked (although not recommended). Forcing it to be enabled (via that hidden flag) does not guarantee it will work. On the contrary, forcing it to be enabled is probably a guarantee that it will be unstable because the browser probably had a good reason for blacklisting the GPU in the first place. Sounds like using chrome might be your only solution until Firefox supports your configuration. Sorry!

I am having troubles with Easel.

I am using Chrome on Windows 10 home edition. I have a relatively new laptop (about 2-3 months old) with an Intel HD Graphics 520 card.

Easel has worked on my PC in the past without issue. Then (I don’t remember making any changes, downloading programs that could be incompatible, etc.) but suddenly the 3D preview stopped working in Easel.

I can still see the preview in Internet Explorer. However, when I try to switch the zero position to the center of the material it reverts back to the lower left corner (it won’ save the change - I ruined a cutting board not realizing that it did this).

I have run through several of the suggestions on the forum (going into the settings to make sure WebGL is enabled, clearing browsing history, etc.) I’ve even uninstalled Firefox and Chrome twice and reinstalled them thinking making certain they were operating by their default settings thinking this might resolve the issue with no success.

I will note that my laptop has gone through some windows updates so I have questioned if those could be the culprit.

Another thought is if my antivirus (Kaspersky) could be causing comparability issues as well.


Thanks in advance.