A better Fusion360 - GRBL PostProcessor

The reason I use G53 in the post-processor is to lift the spindle in machine coordinates : whatever your work-coordinates settings, the spindle will go up to the maximum z-axis.

If after homing you are at 0,0,0 (with the spindle up), then G53 G0 Z0 will lift the spindle to this home z -position.
Typically GRBL stays a few mm away from machine 0,0,0 in order to not cause false limit switch triggers.
So if your machine home is 0,0,0, and you stay 10mm safe, then your safe home position is -10,-10,-10

So the command becomes G53 G0 Z-10

This needs further investigation : simply sending G54 should not cause a problem : it changes the Work Coordinates set to WCS Set 1

@Strooom I don’t think @KikoLobo is using your post processor. Wouldn’t he raise Z and THEN move XY if that was the case? The error he did a screen capture of is not due to the G54, although it appears that way. He probably has an M6 on the preceding line which throws that error in cncjs.

Sorry for the Delay. It was a long night :slight_smile:

So yes, I am using @Strooom pre-processor in Fusion360. I think my mistake is using the easel pre-processor and not the OpenbuildsGRBL one… In the repository it comes with two files. I am using: f360-easel.cps … Will try OpenBuildsGRBL.cps instead.

Here is the first section in the .nc file. As can see in the screenshot there’s both G54 and M8T1 near line 9 [where the controller reports the error]. If the error comes from M8T1, then the error is not the causing issue of the movement beyond the end stop in the Z Axis.

I am switching to OpenBuildsGRBL Pre-Processor. Will let you know if issue persists.

@KikoLobo Did you see my previous reply? The issue is that you don’t have room.

Room for what?
My carves have enough tolerance for the work…

Maybe I need to set the heights for the retract better ?

@KikoLobo
Machine coordinates:
Z0 = your limit switch / home
Z-7.4ish = your work 0 / top of work piece
That’s a difference of 7.4mm. Your gcode is telling the spindle to lift 15mm.
Not enough room.

Is this a post-processor issue? Or a cam job setting issue issue?

The work area is big enough for the job, it’s just that command that rises the bit more than it should. It might be the job settings in Fusion360 for the carve.

Either. Reread my first reply to you.

Got it. Thanks

Will make another go today.

No problem. Again, use default grbl post, and share your Fusion file if you have more questions. With just over 7mm of clearance over your stock, you’ll need to pay close attention to your CAM settings.

1 Like

@KikoLobo Was this resolved? You posted about this everywhere.

Haven’t got a chance to try it! Work has been hectic these days but will let you know

Sorry for long delay.

Issue resolved. Was a bad setup on my part just like @NeilFerreri1 Suggested. I was asking the machine for something that was physically impossible.

Thanks for the assertive advice and the patience :slight_smile:

1 Like

If I am using your PostProcessor for F360 -> CNCJS (XCarve). Is there anything else I should be concerned with?

Hello Strooom,

I‘m a bit confused.

The Z-15 command is lowering the tool -15 mm below Z0. This is not lifting the tool as you wrote, this is lowering the tool.

So all the time I‘m home my x,y,z to the left bottomposition and scratching the tool to the material surface, I zero all axis and send a G28.1 for a new material homing.

The generated g-code (actual openbuildGRBL from the git hub) is trying to ‚lift‘ the spindle up with:
G53 G0 Z-10
G54

But this command is lowering the spindle about 10mm into my material. Crash!!!

I‘m using GRBL 1.1 on my chinese ‚cheese‘ mill Genmitsu 3018-pro.

Is this the wrong post processor or can I change this behavior?

Regards Michael

This move will move the spindle to 10mm below MACHINE zero? It is intended for use with homing switches. Use a different post or edit that one.
G28 is pretty useless without homing switches as well.

Hi Neil,

G28.1 is saving the new xyz zero at the actual position. There are no limit switches in this machine.

Anyway a negative Z value is always moving the spindle down, not up.

If I call the minicom and send a G0 Z-10 it moves the spindle 10mm down in GRBL 1.1.

Is there a setting inside the post processor to change this behavior?

Regards Michael

No, G28.1 creates a G28 position which could be used for any number of reasons. A WCS zero is set with a G92 (temporary) or G10L20 (persistent). Without homing switches, it all needs to be reset every power cycle.

Not true, if my spindle is at Z-20 a move to Z-15 is a move up.

Without homing switches, your machine position is arbitrary. Don’t use it in commands.

G0 Z-10 is a standalone command that could have different results.

If the motion mode is absolute:
If there is a G53 preceding it, on the same line, it is a move to MACHINE Z-10. (could be up)
Otherwise it is a move to WCS Z-10. (could be up)

If the motion mode is incremental:
It will move the Z down 10 from where it is.

Use the default Grbl post.

Hi Neil,
Sure if you at negativ 20 a Z-15 will move the spindle upwards.

But we are talking about to set the home position of our material, which is here at the left bottom if you look from top to the x,y axies.

Then I have to lower my z axies till the tool is scratching the surface.

In GRBL 1.1 is re-setting the x,y,z position to zero of all three axies by using this G28.1 - that is how it is working.

From this position I need to run the g-code, but the postcontroller always writing this Z-15 at a very first command which is not lifting the spindle.

As a GRBL G-CODE it needs to lift the spindle about 2 mm which would be a Z2 command and move the xy to the start position.

This is the whole issue here with my mill, and I still wonder in accordance of the postprocessor description, that the Z-15 command should lift the spindle, but -15 is a command to move it down.

Did I miss understood something?

Regards Michael