Inventables Community Forum

Accessory output

I am planning on putting my dust collection onto the accessory (M7) connector on the x-controller via the Digital Loggers relay-power-strip to my shop vac (that drives a dust-deputy). Anyway, is the M7 pin the right pin (obviously I don’t actually have flood/mist on my x-carve).

The next question I have if so is there a way in the UI to fire the M7 port to on? On my tormach I made my own high-volume flood coolant system and I can turn it on from the controller screen to do a wash down (which admittedly mostly covers myself in coolant more than getting chips into the basin). But there is a nice big coolant button on screen. Is there an easy way to do this in easel so I can also do manual dust collection with a secondary hose?

You could send M7 through the console.

You’re probably at the point where you should move on from Easel, the sender.
I like CNCjs.

i suppose I could write a basic sender application that just has the button… (or i could cheat and use a push button and the power supply in the x-carve in parallel with the M7 pin…)

I suppose…
Or…CNCjs has a button.
image

Damnit, ninja’d. Well I tried the M7 pin into that strip and the relay didn’t fire. Does one have to enable it? with that checkbox for the accessory output in advanced? It seems to imply that’s just for the post-proc to insert the M7/M9 combo… I need to check it with a multimeter to make sure it’s not the relay side that’s not working…

There are special outlets that sense a load on one circuit and turn on another.

It will sense when the router goes on and turn on the dust collection. Some even leave the vacuum on for a minute or two after the router turns off. This might be easier than trying to get fancy.

Oh it turns out this product has a serious flaw: it is sold to men while at the same time apparently (I had to google this) there is this concept of reading the directions that applies here! WTF?

So the little +/- symbols actually mattered… hahaha a quick check with the multimeter confirmed I had polarity flipped. Well that fixed this right up. Now it works.