Accuracy problem on a fully calibrated X-Carve

I’m writing this after trying every possible thing I could’ve think of and to be honest I’m pretty desperate…

Every cut that I make, is consistently off by 0.4-0.5 mm on both the X and Y axis, I have calibrated the machine in every way possible.
Steps per mm is calibrated, belt tension ( after trying a few different variations and getting same result as far as accuracy), V wheels and every nut and bolt on the machine.

I also tried different bit sizes, measuring every bit to make sure that the size is spot on ( even that - with 2 different digital calipers). I can confirm that the machine does not lose steps, tried different feed rates and depth per cut as well as spindle speed, spiral/straight bits and so on…
also tried reinstalling grbl and change setting, but no change in accuracy.

A few more things to mention - I have been using the x carve for over 8 months(Using the “newer” X-Carve with the X-controller, 1000*1000mm), and was getting better results as far as accuracy in the past, between 0.1-0.2 mm. I have no idea what could have changed as I do check my calibration once every week or so. Working both with easel and fusion 360 with UGS.

I’m working with hard woods ( building guitars…) and the last 2 weeks I’ve spent countless hours trying to solve this accuracy problem.
Is there anything that I am missing? any help is well appreciated.
( Sorry if my English isn’t perfect…)

Tool run-out?
Tool deflection?

If F360 is your CAM, have you checked “Stock to Leave”?

Hi there sorry to but in but i think this is the issue i have in fusion. please elaborate on this stock to leave. I zero out my z and my first pass will be too deep would this possibly be my issue. been going on a few years and never resolved this as of yet.


If you do not edit the default settings in F360, zero Z at actual material height your actual cut depth will be your design Z + 1mm i addition.

You need to edit the stock options under your main Setup folder, highlighted in blue, see screenshot below:
(Set Stock Top Offset = 0mm if you want that surface to be your machined 0Z

Stock to Leave is a preset you can choose under your specific tool path properties.
Purpose is to say leave 0.5mm (value arbitrary) of material from the roughing pass and then do a finish path to shave of the last 0.5mm.

Thank you very much.

So if you cut a circle is it a perfect circle just 0.4mm to large or too small? How are you measuring the size of your bit? Have you tried adjusting the size of your bit to account for the amount you are off ?

You don’t mention if you’re off on the small size or on the larger size. I’m gonna assume on the larger size.

Try remeasuring your bit. maybe something slopped up in the Dewalt with your usage.

@GilMaor is it off by the same .4-.5 mm if you use Easel or only when you use Fusion 360?

@Zach_Kaplan @HaldorLonningdal @AdamWagner

Hi, thank you very much for your replays!
It does NOT matter if I use easel or F360, the cut is still off by 0.4-0.5 mm.
Changing bit types or sizes doesn’t really affect the result, as well as changing feed rate/plunge rate/spindle speed.
This isn’t my first time facing a problem with the X-Carve, but this time I just can’t find the solution!
When cutting a circle it is “perfect” but smaller in size, 0.4 - 0.5 off as mentioned before.
I always measure my bits and cuts with more than one digital caliper, more than that, parts that used to fit in aren’t now.
As I said before - it is very frustrating for me as I used to have the machine way more accurate a few weeks ago and it worked great for about 6-7 months. I just can’t figure out what could have changed with my setup.

It sounds like a systematic issue. Since it is so consistent across software it seems unlikely to be software or hardware.

My hypothesis is it could be a firmware setting that changed where the number of steps per revolution is off.

Can you go into the machine inspector and type $$ and post back your settings?

Here are the GRBL setting.

@PhilJohnson @Zach_Kaplan
I did some changes over the time to the steps per mm, but ended up using exactly 40 steps p/m, and it worked really great for months.
@PhilJohnson - Read what I wrote before, I got good results in the past with the same setting regarding steps per mm, I did got to 0.1 mm accuracy in the past. Even now when I manually jog the machine via UGS/Easel it does move very accurate as before. The problem that I have is very much consistent among different size curves and bit sizes…
It make no sanse that I’ll be getting the same 0.4-0.5 mm off, with different size circles or rectangular, the cut is off pretty much the same amount when cutting a 55 mm rectangular or 5050… so the problem is NOT the steps per mm.
The only thing I can think of perhaps is the stiffness of the gantry… what I can’t understand is why this problem suddenly appeared, the machine did worked quite well for a long time and I do check my calibration regularly

You can always fudge the bit size to get a exact cut try making your bit 0.4 mm smaller than it is now and it should cut close to dead on again . As for what is wrong why it all the sudden is off?? That’s a good question I initially thought spindle run-out but that generally gets you larger than you want so a consistent undercut should rule that out … steps per mm calibration have you tried measuring a very small distance like 10-20mm and see if it is off ? Don’t set your x carve on those small distance just measure to see if it’s off ! Have you had any accidents where you ran the spindle into a clamp or anything of that nature ?

I’d recommend making it 0.2mm smaller if you’re going to do this. Assuming your 0.4-0.5mm is diameter/total size, you only need half of the error per side to get the full total, if I’m doing the math right.

Also, this may sound crazy, but when was the last time you checked your batteries in your caliper (assuming you’re using a digital caliper)? I’ve had not fresh/low batteries affect measurements on other instruments before. I’d consider replacing that as well to make sure the measurement itself is good.

1 Like

Good call IDK what I was thinking lol

I’d adjust your steps per mm. Maybe a belt slipped a tooth, or the belts just stretched a bit, or the tension changed a whisker. I believe most people run a calibration on steps per mm every so often. Someone linked above to the method for adjusting it.

Have you tested calibrating the X-Carve along a long distance?