Adjust feedrate?

I’m adjusting the feedrate in piclaser then sending the picture in pic sender. Whether it’s a feed rate of 200 or 10000, it’s not changing speed and it’s charring the heck out of the wood. How do I fix this?

What version of grbl are you running? If it’s not a version for laser use, the S commands will dwell on every line of gcode and run slow.

1 Like

Jtechs version of Grbl

There are two versions of J-Tech grbl. Version 9g & and Larry’s 1.0c. Which version does it show after connecting to the com port?


Jtech 9g

You need to make these changes to the grbl settings to increase the axis movement speed & performance.

$0=30 (step pulse, usec)
$1=255 (step idle delay, msec)
$11=0.005 (junction deviation, mm)
$120=6000.000 (x accel, mm/sec^2)
$121=6000.000 (y accel, mm/sec^2)

Also engraving at a 45D angle will run smoother/faster.

There is a MultiMode grbl version that can be downloaded from here:

There is a link for setting up PicSender for it there also.