All assembled and X-carve won't work

Hey guys, Spent almost every night over the past week assembling my X-carve. I got the arduino driver and easel driver installed. started up the machine and went to set up the machine in easel. The first time I tried the pc recognized the machine but when I went to test the movement on the different axis nothing moved. Figured the Gshield wasn’t seated properly. I think I got it. When I move the axis by hand the green lights come on. Turned the maxchine back on and I get all three green lights but no movement. I can’t even move the axis by hand. tried rebooting. now I get all three lights flashing green and the motors sound like they are trying to work then shut off. still no movement. then the pc says to plug in usb and turn on power but doesn’t go to the machine setup up afterwards…

no Idea where to start


Thanks guys

What operating system are you using?

If the steppers feel held in place when you turn them on, then they are getting power. Have you double checked the wiring to the board?

using windows 10 and using chrome for the browser.

Brad, are you referring to the x,y,z axis wiring into the gshield?

You should have a blue light on as well. I’m not next to my X-carve at the moment, but I believe it’s to the right of the 3 green axis lights.

1 Like

yes the blue light is on as well. and the fan is going.

ok so now all three lights are on and the window in easel says configuring z axis for acme, pretty sure it is stuck there? any clues?

I recall having to refresh the page, or go back to the beginning of machine set-up and run it through a few times before it would go past the z axis configure page.

ok some progress but still issues.

  1. I was using a usb extension cable (maybe 10’) so I could have the tablet pc farther away from the dust. Removed that and hooked it straight to the included usb cable. got as far as homing the limit switches. was able to move all the axis from the pc. it went to home the z axis and i dunno if it got stuck between the dewalt 611 plastic head and the z plate but now i’m back at square one. can’t even get into the machine set up and when I can trying to move the axis doesn’t work. have no idea where to start. tried rebooting the pc, tried closing chrome and trying again. no luck.

So I had some success, I think I figured out my problem. I’m running it off of a surface pro 1 so there is only one usb port. I had a 4 port usb hub hooked up so I can use a mouse and the X-carve. unhooked that and hooked the X-carve directly into the surface. No Problem with setup, homing worked perfectly, then was able to do a test cut and it turned out great.

Guess my option is to buy a bluetooth mouse.

I’ve seen some discussion on this forum about using Chrome as a browser. Apparently there are some issues with Chrome. Try using a different browser.

Glad you were able to get it figured out. I bought a powered USB hub to help with my connection issues, so that is an option too.

Is the USB hub powered?

People have been having issues with not enough power getting to the controller over their USB.
One fix is to use a powered hub. So you may want to give that a try.

If the problem is getting power to the Arduino, it can be powered externally using a 7-12v DC wall wart/power supply.

There’s also a Vin pin on the Arduino that can be used to power it. I had assumed the Gshield was applying power to it through that since it is connected. I guess it is not.