All axis moving in wrong direction

Evening guys, (noob here) just finished assembling my X-Carve. Everything went smoothly. Figured I would use Easel to see if I could get my machine to move some and call it a night. Well all the axis are moving opposite from the controls in Easel. I have checked the wiring on the X-Controller and it seems to be the same as the pictures. I have been reading the forums and can’t seem to find an answer. Any help would be greatly appreciated. Thanks Roy

That happened to me too. You can either reverse it in software or flip all the green and black wires (power off first).

Easel bugged out for me on the software fix (Mac running Safari). So I just swapped all the wires.

Maybe it is a Mac/Safari thing. I had the same problem during initial set up (running Safari on Mac), but decided to fix it through the software that David mentioned, the “Set up your machine” option under the machine tab, which gives you the option to reverse it. It’s also a one time fix, but either option works.

Go through easel machine setup, there are arrows and an ok button when you are satisfied, this will alter the dir mask in grbl.

1 Like

For those who are curious about the Grbl invert bits — I finally worked up a compleat table on this:

http://www.shapeoko.com/wiki/index.php/Grbl#Grbl0.9

Current settings         X  Y  Z X&Y X&Z Y&Z XYZ
0 (X=000, Y=000, Z=000)  1  2  4  3   5   6   7  
1 (X=001, Y=000, Z=000)  0  3  5  2   4   7   6  
2 (X=000, Y=010, Z=000)  3  0  6  1   7   4   5  
3 (X=001, Y=010, Z=000)  2  1  7  0   6   5   4  
4 (X=000, Y=000, Z=100)  5  6  0  7   1   2   3  
5 (X=001, Y=000, Z=100)  4  7  1  6   0   3   2  
6 (X=000, Y=010, Z=100)  7  4  2  5   3   0   1  
7 (X=001, Y=010, Z=001)  6  5  3  4   2   1   0  

and Shapeoko forum user CastIrony was kind enough to work up a script to test my having done it by hand: http://www.shapeoko.com/forum/viewtopic.php?f=17&t=8607&p=66319#p66318

I think the issue with Easel has not been fixed. I started with Easel and changed all three directions but when I went back in everything was wrong again. Thanks for all the help guys. Tomorrow I will try and get UGS to connect. I am getting the still booting error. LOL

I still suggest flipping all the green and black wires. It takes 2 minutes and is guaranteed to work.

Same problem I had with Easel, X and Y were backwards, no matter how I changed it, it still didn’t work. Found if I changed ONLY X and finished the setup, THEN went back and changed only Y and finished setup it would keep remember each one into the grbl memory.

1 Like

Check to make sure that your baud rate is set to 115200.

1 Like

You’re correct. Can swap either green and black or red and blue wires, just not both sets or the stepper motor will go in the same direction as before.