Annoying Spindle Starts and Stops

How can I stop the spindle from stopping and starting while moving to a different location? Extremely annoying!

1 Like

It sounds like your cnc is in laser mode.
Youd need to change it to spindle mode by setting $32=0

You can go to machine inspector by pressing ctrl+shift+D and then scroll to the bottom to locate the grbl settings. I suspect $32 is cirrently set to 1 (laser mode) if so you can scroll back up to the top and type $32=0 into the console section and send that command…
Scroll back down, press the small refresh icon and verify that $32=0 is saved properly. And the spindle should function normally, remaining on throughout the carve.

Thank you! That did the trick. The odd thing, is that it just started doing that in my last 3 carvings. Prior to that, everything was OK.

1 Like

Same problem here, spindle stop and start, assumed it was in laser mode, but worked fine previously.
When doing repeat carvings and using ‘use last position’ then ‘turn on spindle’ it would not turn on, program would run and spindle would turn after traversing. a bit worrying as your telling it that the ‘spindle is on’ and hitting ‘carve’ and not sure if it going to crash into the work piece.
How did the settings change? would it have anything to do with the power adapter going bang about 2 seconds into previous carve, new adapter and $32 change all good again.

Have you used a laser module on that machine? That is the only reason the $32 would get changed is if the operator changed it during the setup of a laser module on the machine. :man_shrugging:

Hi
Laser has not been run when connected to this PC only carving with Easel, did install laser grbl recently on this PC but never ran the machine with laser.
Connected laser grbl just now out of curiosity, and checked $32 , thinking that connecting maybe sets $32, but it’s still at 0.
re run easel and spindle turning on, works fine.
Have know idea how $32 changed to 1.
regards

1 Like