Another attempt at carving a photo!

OK folks, here we go one more time. I now have the machine carving in a 33 degree angle again. Don’t know what the problem was before, but it has gone away to be replaced by another one! It seems my machine only wants to carve in miniature now. I have set my carving up for a 5.5 inch ‘Y’ direction and it auto sets the ‘X’ direction to a little over 4 inches. When I press ‘send’ it starts but is only cutting about 1/2 inch in the ‘Y’ direction and 3/8 inch in the ‘X’ direction! Tried deleting everything and redoing only to get a similar result, I say similar as I canceled the carving. No need to sit for 27 minutes watching it carve 1/2 X 3/8 inch area! Any thoughts, anyone!

Try reading this post started by @AlanDavis [Solved] X-Carve enlarging image. Judging by what you are saying, it sounds like this could be a similar problem.

In this post @TaitLeswing explains how to clear out the EEPROM and get it setup with the correct code. Hope this helps.

DrewTaft, I read the thread and dude, that’s all greek to me!

1 Like

What is your setup like? PC or Mac? 500mm or 1000mm? What version of Windows (or OSX for Mac) What are you using to get the G-Code to your Machine: Easel, Universal G-Code Sender, GRBL Controller< etc.?

We have a 500mm machine that is connected to an old laptop that still runs Windows XP. I initally set it up with Easel and started sending Code with GRBL Controller, but switched to Universal G-Code Sender vafter I ran into problems.

Another thing, if you don’t mind me asking, how comfortable are you with setting up & working on the computer side of all of this? I ask because I don’t want to sound condescending or go over your head either.

I have had so much fun with our machine since we received ours, ESPECIALLY after I got some bugs worked out. For example, while reading through some of the troubleshooting posts, I realized that our machine was not getting enough power to the motors (we chose the NEMA 27 motors). This was most evident on the Y axis, where there are 2 motors that share the same power. When the machine was getting close to the end of the rails or when was moving long distances I would hear what I would call a growl. Like the belts were slipping, so much so that I tightened up the X & Y belts again. Turns out that there are 3 dials on the G-Shield that control how much power is sent to the motors and following the lead of others in the forum, found that I needed to add just a little bit to the X (like 2 tick marks) and quite a bit more for the Y (like 4 or 5). I didn’t mess with the Z power since I haven’t been able to find any slippage there.

When researching thing while we were waiting for the X-Carve to arrive, I thought that GRBL Controller was the way to go for a G-Code sender since Easel isn’t setup for 3D at this time, but (again while reading in the forum, here) I found that many were using Universal G-Code Sender, so when I tried running our first code that was generated from MeshCAM and had some difficulty I tried UGS and that was so much easier and user friendly in my opinion. Easel is the easiest to use and what is recommended to setup machine.

I would like to help, if I can. Since there were others that I benefitted from.

Drew, don’t worry about sounding condescending, dude I’m lost with most of this stuff. What I know about computer code and such is all self learned from fooling around with it. I have received much help from many sources and I think I will beat this thing yet. I bought a used pc running XP, It seems to work just fine with easel but I want to do photo carving so I have java version 7 installed and USG version 1.0.8 installed. As easel is very easy to use I have no problems with it, but trying to run USG has been a bit of a challenge. I have something I need to check when I get back to it later today and see if it fixes my problem. I have the 1000mm set up and have had no problems running with easel, have made several name plates/tags with no problem. No voltage trouble or running problems, seems to work just fine. Thanks for the offer of assistance, please keep up with my progress via my videos and from chat.

I know so much going on on that post. Let’s make it simple, I shrink the post. To do this, you have to have X-loader and correct Hex file. Just read this instruction, I will find Hex file and share it.

Open the Arduino IDE

Go to File - Examples - EEPROM - eeprom_clear
Click it,

Find this line,

for ( int i = 0 ; i < EEPROM.length() ; i++ )


for ( int i = 0 ; i < 1024; i++ )

After upload finish, close Arduino IDE, open XLoader , Make sure all your settings are correct
Device = Uno(ATmega328)
Baud rate 115200
Load HEX file name = grbl0_9i_X_Carve_500mm_ACME.hex

Close XLoader and start Easel, run machine setup.

That what I did and I started to run production.

If you don’t have any of those loaders or HEX file, let me know I can give you links.

Here I found what you need.

Hex file says 500mm, don’t pay attention. After uploading is successful, you must run Easel Machine setup, it corrects to 1000mm.

Note: I’m not in my office, using my iPad. The link I sent for hex file might open in Note, all you have to do is save it as txt, change extension from txt to HEX. This time you’re able to load it to X-loader. Don’t forget to check X-loaders parameters. Must be atmega Not mega atmega and speed is 115200.

Alan you have totally lost me on this one. You are way above my operating level. What is/how do I go to Arduino IDE? I am assuming once I find this place there will be a file menu to drop down for the rest of this. I am not so sure about messing with this device as I really don’t want to mess it up beyond all repair. Next what the heck is XLoader? Never heard of this device/program before. Also don’t know what a HEX file is. Told you, you are way above my computer experience with all of this.

@JamesMitchell and @AlanDavis

If the machine runs fine in Easel, then don’t go through the trouble of uploading a new HEX. This is really more than is needed to be done. The machine and electronics are already setup fine.

If your carve from V-Carve is set up in inches and you are using the X-Carve inches post processor for V-Carve, make double sure that UGS is in inches mode and not millimeters mode.

Is your machine running fine with Easel.???

That’s what I figured. It runs just fine in easel and yes I set it up in inches in vcarve and verified it is inches in UGS. I verified all this this morning and tried running a carving and it is still doing the minuter carving thing. Now I don’t know what transpired yesterday, but the day before it was doing just fine and to my knowledge, I changed nothing. So go figure?

Yes it is.

Then, you have to listen Scetch32 and stick with Easel. Sorry I didn’t think about your Computer level. Easel is Web based application runs smooth as long as you have good mechanical adjustments. If you have any unrecognized numbers on your Arduino Eeprom, UGS doesn’t work. We call garbage in the HEX. That’s why I sent you those files. Never mind. If you still having problems with UGS or any other sender programs, you can contact Tech Support and request Flashed Arduino for exchange bases.
Is this problems happening while trying picture carving?
Do you have V-Carve Photo installed?
Is that copy of Photo Carving software registered.?
If you can put little clear information I’m sure you can get help in here. We have good bright friends here, they never hesitates answering questions (On-Line)

I’m assuming you meant ‘sketch42’. Now to answer your questions, 1.) yes while trying to do a photo carve, 2.) yes I do, 3.) registered, I don’t know about that? All I can tell you is that when I first tried photo carve it would carve the size I told it to, but it would only skim the surface. Yesterday it went from carving (skimming) a photo sized area to now only carving (skimming) a 1 inch X 3/8 inch area. I am using the photo’s in the tutorials on vcarve photo.

1 Like

Yes I meant sketch42, you’re good for spelling, I’m not. So wait here, someone help you better. Good luck.

You might want to give ChiliPepper (for GRBL) a try.
It is a web based gCode sender.
I have seen that some of people who were having problems with UGS had better luck with it.
At least until you can track down what setting is screwing up your sizes.

I had the same problem you want to manually send the g20 command to put your Grbl into inch mode

The reason it is printing so small is the gcode file you created is in inches and the machine is in mm

Alan Davis, I only mentioned the sketch42 because it caused me some confusion until I figured it out. NOW, I looked back and I can’t find that g20 command you referred to. I remember reading somewhere about it but can’t find it now, so if you would send it to me once more I will give it a try. Thanks