Another day another issue

To get a better “reading” set step over to 80-90% instead of the default 40% which will give you a wider width per pass :slight_smile:

Also you’re doing Offset, try Raster instead. That way you don’t have that center, it goes left to right/right to left.

How do you set it to Raster instead of Offset?

I’m not super concerned about the lines they are so small i couldn’t even feel them on the board. I tried adjusting the eccentric nuts on both sections on the z azis and can’t get it any closer than I have it now. I don’t plan on making a ton of items with smooth bottoms and the few things I do, a little sanding wont kill me.

I have aspire, I only figured on using it for complex applications but I might try it for some simpler drawings.

Yeah I used finishing pass on a set of coasters I made it definitely made a huge difference.

1 Like

Do you send your g code through easel?

Ok, I have been thinking about switching more to UGS since I am already Zeroing in UGS and then switching to Easel.

And the ongoing saga continues.

This morning I woke up to rerun the cut that I did last night that actually turned out exactly like I wanted except that I didn’t measure the bit so everything was just factually smaller due to my .125 bit being more like .122.

And then it happened. I started to cut and noticed that it started way further over then it had last night nothing too much of it since it was just a scrap I let it go for a second only to realize that it was way too far and that it was going to cut off of the material. I stop the job and returns to zero only to notice that it’s way off again.

So I jog it back to the zero manually and notice that it’s traveling really fast. Somehow overnight my x-axis now travels about 2 inches for every 1 inch requested.

So my question is WTF? I am assuming that Arduino doesn’t push out software updates to the equipment. I’m also assuming that easel didn’t over right my previous coding since I check the $$ and the values for both correct. So what would’ve caused this issue? The only thing that I changed between this morning and last night was the bit size. I literally woke my computer from sleep mode and turn everything on that is all.

You can see in the picture the box starts way further away.

I leave my router pretty close to the front left corner when I am done and then manual rezero before each cut.

here is the actual file:

This is the second square the one that was further away then it should be, I stopped it after the first depth cut thats why its so light. The boards are right up against my stop so the bottom square should have been where the top square was.

I can definetly turn it all the way off instead of sleep mode, I just do that to save time. I still don’t understand how this would effect how the stepper motors where operating. But if you think it is causing a issue I definitely can change it.

Please check your position under Machine Inspector (CTRL+SHIFT+D, or CMD+ for Mac) that the given coordinates matches your intent :slight_smile:

Yeah that not 100% my issue it wasn’t that the work / machine zero was off it was that all of my x steps where twice as long as they should have been.

I verified in UGS that when I tell it to go 10mm it is in fact going 19.8 mm.

My issue is why, I didn’t change anything btw today and last night and my values for $100 & $101 are both the same as the previous day.

I understand that - it sounds odd that a change like that happen “for no reason”
I can only think that a sudden 2x increase in travel, with the same base parameters present is due to either an electrical malfuction (reboot and retest) or some how the microsetting value have been changed (in either GRBL/hickup or short circuit on the board)

1 Like

I did reset the Arduino by manual turning it off and disconnecting it, the problem remained. How would I test for the other problems.

Can you post your GRBL settings?

Do you mean the $$ settings? I will do that as soon as I get home.

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=115 (status report mask:01110011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=1. (rpm max)
$31=0. (rpm min)
$100=39.841 (x, step/mm)
$101=39.801 (y, step/mm)
$102=187.291 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

OK, I don’t know why but this actually worked. I unplugged all the power from the Arduino and reset my computer and now 1 inch is 1 inch. Do you have any idea what could’ve caused it

I didn’t change any settings I simply unplugged the USB and turn off the AC power going to the Arduino and then I reset my computer I literally didn’t do anything else.