Another VCarve to Easel isnt working right post

Came across many of these posts but nothing Ive come across seems to do the trick in my case. Ive made Easel my PP in VCarve but when I import it still pushes my drawing to the upper and right edges of my work piece. I fiddled around long enough to make it work manually but I need this to just happen instead of making due with manual manipulation. On top of that, after getting it where I needed to run it, the program cut half and stopped saying it was completed.

PLEASE I need a life line before I get in trouble for Hulk smashing everything in sight :joy:

Not sure what’s causing this problem. The PP you selected must match the unit of measure. If you designed in inches, then make sure you select the PP that is in inches. Take a look at this video. I designed in Vcarve and used Easel as my gcode sender. Maybe you will see something that will help you.

@AaronTLynch Can you share an offending V-carve file? It has to do with your work zero.

If I can figure out how to I’ll happily do it

Do you see an upload button when you reply?

When you begin VCarve, where is your x,y position? It will be the same when you go to easel. For example, if the position is in the center of your project, then when you send the gcode to easel you must set your x,y axis to the center of your project. You can not change anything in easel

I moved it to the bottom left corner

Fox’s Table 2.crv (8.0 MB)

There is the VCarve file. its pocket 1 thats having the issues. Havent tried any of the others but Im assuming its all the same. Thanks for looking into this

Is Easel a “must” for you?
UGS might be a viable solution…

I have no idea what UGS is and what my limitations are. Im just now getting into the ‘hobbiest’ side of things. Use large machines at work but wanted to give the home market a try.


Easel is not required for your X-carve to work properly.

Think of the X-carve as a serial device. All you need to make it work is a program to send a G-code file (contains simple text commands for the X-carve) to the device and receive responses from the device. Universal G code Sender (UGCS, or UGS) is one of the many programs you can use to send the G-code to the X-carve.

You do have to make sure that you use an appropriate “post processor” so that Vcarve will generate G-code that is specific to the X-carve.

I use UGS platform with Vcarve Pro.
Just output the toolpath for x-carve.

UGS is pretty plug in play, Set your baud rate to 115k, Click the connect icon. Home your machine.
Do you know G-code so you can set your zeros? or do you need help with those macros.

Aaron, in your original post, you said you used a pp for Easel (or words to that effect). Just wondering if that’s part of your problem.

Keep in mind that I don’t use Easel so I may be wildly wrong, however when I create files in VCarve, I use a post processor specifically for the XCarve (for me I use the metric one). I’m assuming that all you’re using Easel for is to stream the gcode to your machine, so I assume you should be doing the same.

Maybe there’s an Easel guru here, but I’d assume you should perhaps be doing your design in VCarve, creating your gcode in VCarve using the “XCarve” post processor, and then loading that resulting file into easel and then running it.

Thanks for the idea of running a UGS guys. Im not use to all these issues. Guess thats the joy of having a machine like this. And I have 0 experience with G Code. At work I draw, make tool paths, transfer the file and watch it go.

David, Im grasping at straws. Only reason I added it. VCarve wasnt working so I tried that. Still not working properly. It always moves my part to the very top and very right edge.

To top it all off, after trial and error of getting it where I need it, at some point my machine loses connection with the laptop and it ‘finishes’ the program. After about 3 hours of cutting yesterday it did this. So I reload everything, tell it to use the same home parameters, and whats it do… goes from bad to WORSE. Instead of recentering and starting over, it decides to plunge and by the time Im able to tell it to stop, its all the way through my piece. And the icing on the cake, even after I stop the program, about 5 seconds later, it decides to make a cut about 5 inches long right through the piece. Not sure how or why since I stopped the program, but what do I know. The 1 thing I do know is Im starting to regret buying this thing cause literally all Ive had is issues

Aaron, getting everything dialed in can be a journey unto itself. Keep at it.

Go to the UGS website and look at the platform nightly build. There are some walkthroughs on this forum regarding its use.
If you have a touchplate, its very easy to set up some macros to touch off everything. If you need help with this, we can help.

I personally use a bump plate with a G28.1 command at the corner. That makes my X and Y zero the same for everything I do, unless its a special project that requires changing it. This way, I can turn everything off, Power go out, Santa Clause not liking what im doing, and always return to the same zero position.

Keep plugging away, and look at the bright side. Think of all the things you are learning about your machine along the way

Is the UGS yall are referring to the Winder one?

Yes, there are three variations in use:

  1. version 1.0.9 last stable release
  2. version 2? (the nightly build)
  3. the Platform version.

I believe that they all require Java.

I run 1.0.9 because it is stable, but it has problems with large G-code files. I use PicSender for very large files.

Easel won’t do that on it’s own.
Can you explain what you mean? Is the preview in the top right? Is the preview good, but it’s carving top right?
Can you share a screen shot or photo.
Here’s what I get using your file:

Yea that’s what it does to me. But it should be in the middle of the work piece as its drawn in vcarve.

What is considered a large file?