Anyone else get a bad unit?

First off, I’m not here to bash the Pro, Inventables, or the wonderful tech support staff. I have amazing luck and always get the “lemon” in the bunch. To be fair, Inventables has offered a ton of discounts and other perks, all of which I have declined because I’m not looking for anything free, to make this right. Just curious if anyone else is having these issues so hopefully we can reach a solution. I love the potential of the machine. I have had my machine about 40 days. I’m currently on the 3rd control box, the 4th is coming tomorrow. The second unit was a non working unit that was accidentally shipped. The current unit arrived beat up with screws missing and the circuit board wired incorrectly(Y1 and Z moved together while Y2 was stationary.) My machine will not home, the switches are set too far back to reach the pillars. I constantly loose Z setting and either cut air or deep dive. The gantry will take off in the middle of a cut and slam into the Y2 support, even though the cut section is a 12"X12" on the Y1 side. It will randomly stop while carving and drag the bit back to 0, I’ve broken several hundred dollars worth of bits so far with it doing this. I’ve tried using factory settings, speeding up, slowing down, and nothing helps. I have tried importing projects, using projects from the forum, and drawing simple ones myself. The end result is the same. A simple heart cut great on the first pass and then 4" off on the second. Another carve started perfectly and ended cutting 7" above the top of the pattern. A 12" straight line with a 90 degree Vbit moved up and down almost 1/2" from one end to the other. Everything is level, wood has been planed, secured with clamps and cnc tape. Thickness is verified in multiple places to .001." Anyone have any ideas on what I can p[ossibly do to get better results? Any help would be greatly appreciated.

1 Like

You’re not alone on that exact same failure with the return to origin while the z is still in the plunged position. Multiple posts over on the xcarve pro Facebook group.

I’m not part of their staff, but I would probably check the belt tension, get a super good usb cable and a powered USB hub, and verify all of the grbl settings… they probably already had u do this last part too, but here’s what I have for defaults just to double check:

A few ppl reported $1 not being set to 255, and that causes the z to start falling immediately after the z is probed, so if that is set to any other value, that could be part of the issue.

Thank you! I’m not on Facebook, so I have not seen this. I really do appreciate it. I really just want this thing to work. I purchased it because my daughter, she’s 6, suddenly started making her own “heart” furniture and after a ton of research I thought Easel would be a simple program to use. All of my kiddos are adopted out of foster care and I saw a great opportunity to bond with her. That’s why I’m so frustrated with all of the hiccups, I feel like I let her down since I played up all the things we could do together. So far I’m batting zero.

1 Like

I had these same issues with broken bits and the Z axis dropping, as well as having to my Gantry get stuck because it wasn’t hitting the limit switch. Support was amazing from inventables but it was a good solid month of back and forth before we got it all worked out. But everything has run like a dream since then.

Now if they could come up with a better design for the dust shoe…it somehow manages to catch the knobs on my clamps no matter where I put them…:man_facepalming:t2:

Pixel to Prototype makes a dust shoe that clamps to the spindle. I got with them awhile back and had one made. It is on thier site for the 58mm spindle (if I remember correctly)

I had same issues, the new firmware update did the trick but i just had my gantry get stuck all the way on the right side of the machine. Any help on how to get it unstuck?

If I’m not mistaken, this is the same dust shoe as the “suckit dust shoe”
(I don’t believe its available anymore)
((Which I don’t understand, because its a great dust shoe))
I bought one some years ago and had the same problem.
Here is your solution.
Buy the 2" brush and trim it to just clear your clamp screws.
mcmaster carr

@JanVanderlinden, I think the OP is talking about the XCP which has a different dust boot. It might still accept the same bristles, but I can not comment to that.


I too have a SuckIt Dust Boot on my X-Carve, and I too have had great success with it.


Brandon Parker

Ok, Sorry.

No need to apologize; all positive contributions are great even if a little off the path by accident. Even if the bristles are not the correct ones, the information is a starting point for the OP’s search.


Brandon Parker

If you are lucky the stop ring on the far right is in a position where you can loosen the hex screw to release the tension on it. Once you have it loosened you can just push the gantry over with your hand.

Good Day, I have the YoraHome (believe yorahome and inventables are one in the same)
yes, our first box is bad and waiting for the replacement to show up

Welcome to the Forum.

Yorahome is a fully China based company with a US trademarked name and a US “warehouse” address (look up the US address provided on the YoraHome website contact page, its a residential home with multiple LLC’s showing at that same address)
Yorahome uses the same manufacturing facility in China as SainSmart, FoxAlien, MySweety, and others.

Where as Inventables is a US based company with a physical offices in Chicago, IL

These are NOT the same company.
Your issue with YoraHome is completely unrelated to Inventables.

I stand corrected , thank you

1 Like

Oh goodness, I feel bad for you, but I hope I don’t have this bad of luck. My machine was delivered way earlier than it was supposed to be so unfortunately I haven’t even unboxed it yet (was out of state for medical reasons and luckily my neighbor received it). If that takes awhile, I hope they’re still willing to help with any out-of-the-box issues.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.