Anyone else getting nasty Javascript errors in Firefox?

This just started happening to me:

I was attempting to help troubleshoot someone’s project, but every time I tried to open the link they provided, Easel would cause Firefox to hang. It opened fine in Safari.

Ok, fine, maybe their project is buggy. So I open one of mine. The project opens just fine but when I try to run the Inlay Generator app it hangs Firefox when importing the new svg paths it creates.

Hmm. The plot thickens.

So I start a new project, and when I try to import an .svg file it hangs Firefox again.

I deleted and fresh-installed Firefox, and am still having issues, only this time it gives me an “unresponsive script” error, which at least allows me to stop the script from running and gives me back control of Firefox.

Is anyone else having problems like this?


I don’t know if it is related but I can get all the way to trying to create g-code (for export) and boom it hangs. I tried firefox, chrome, edge, explorer and safari on a mac. 3 different computers 5 different browsers same problem. Must be something wrong tonight.

Hi everyone,

I’m sorry for the trouble! This was caused by a bug with some internal changes that we deployed last night. It should be working again now.

Thank you @Mike and @TrevorSeaman for reporting the problems!

Thanks for getting it back up and running so quickly!

I am having the same problem using Firefox so I tried in Microsoft Edge and Explorer and am experiencing the same problem. Any suggestions will be greatly appreciated. Thanks!

Hi Bud,

Easel is designed to work in the most recent versions of all major web browsers. It is unlikely you are having the exact same issue reported in this topic, as that issue was fixed and closed. If you are having a problem, you should definitely contact Inventables customer success. There is a “Support” button at the top of the page.