Inventables Community Forum

Anyone recently had any luck with the Linux Driver for Easel?

Hi

Recently got a cheap 2nd hand chromebook to install linux on and try to use as my xcarve controller. Ive managed to get the driver installed but when i connect the usb it still asks to install the driver as if i have not.

Is the linux driver actively being supported or am i running down a street with no end here?

Thanks

Hi,
Linux driver is fully supported on Ubuntu 18.04. Using chromebooks with Linux installed is a non-standard setup that we have not tested, so we can’t guarantee that driver is fully operational. Can you share a bit more about the configuration you are using?

as a Linux user I would like to ask.

  1. what version of Linux are you using?
  2. is your USB port active?
  3. how is your USB port listed?
  4. do you have read write access to the USB as standard user?

with this information we can help you make a better determination of the exact issue.

Hi

Yeah i totally understand its not an officially supported setup. Just wondered if any others had some luck it it. Im running ubuntu via chroot. Driver seems to install, just doesnt seem to be acknowledged in the browser. Hopefully someone in the community has come across the same issues.

Probably should have just picked up a cheap second hand windows laptop rather than going this route but I am where i am now :smiley:

Hi

excuse me if my answers are a bit vague. Im a total newb to the world of linux so ill likely talk some nonsense so ill apologize now if i cause frustration. Any help at all is supremely appreciated. If it turns out to not be possible then that’s fair enough.

Im using Linux ubuntu with the xfce4 desktop via crouton. Ive tried a couple of the distros that crouton supports with no real luck. This current setup does at least install the driver, it just does not seem to do anything when the usb cable is plugged in. You may be right that my usb ports are possibly not active

If you can tell me how to check if they are active and enable read access ill get back to you with as much info as possible. Genuinely appreciate the help. Just looking to not have to run my nice surface laptop along side my dusty xcarve!

sudo lsusb -t

should show the ports and what is connected to them

Thanks Kenneth.

When i run the command with and without the usb attached and the machine turned on there is a difference. This line is added
Port 4: Dev 9, if 0, Class=Vendor Specific Class, Driver=ftdi_sio 12m

So it does at least look like the ports are active. No luck getting easel to see machine though

it looks like your port is open and working. the next thing I would try is to make sure your user is authorized to use the port.

try:

sudo adduser “your user name” dialout

Thanks so much. I’ll try this once my current carve is done

Sadly no luck still. I added self and it now says im part of dialout but still no green button.

Okay.

the next thing I would do is download and run UGS from https://winder.github.io/ugs_website

and unzip and run UGS

the reason being you can then select the port and baud rate manually and get a better ideal what is going on.

if UGS can open and control your X-Carve then the problem is within the software (driver) if not then the problem is within the port or connection.

this should help narrow down which path is giving you trouble.

Sadly not managing to get UGS installed. I think i might strip out this crouton install and try install ubuntu on a second mount. Hopefully get a little more compatibility with things. This installation seems to have multiple issues

let us know if that helps or changes anything.

really like to see you get this going.

I use a Raspberry Pi 3 to control mine and I am completely happy with the setup.

Ill give it a go tomorrow if not ill have to explore the pi option. I have a spare one sitting about. I just cannot afford to have my nice laptop sitting getting filled with dust next to the X-Carve. Really do appreciate your help!

the nicest thing about the Pi is no fans to draw in dust.

it is very small and quite, I use a wireless keyboard trackpad so I can make small jogs while standing over the machine which helps me.

apart from Easel I also have used CNCjs (browser based) Chilipeppr (browser based) Bcnc (python) Universal-G-Code-Sender (java =no visualizer but can handle huge g-code files).

Of these I use Easel then UGS and lastly Bcnc, I found that browser based programs could not handle long g-code files due to size limits with browser security. and when I use the laser some files get very large.

I can say that using the Pi has been the best. and if it ever fails it is just $35.00 to change or upgrade.

Hello, Easel driver works on cnc-machine from win-10 but on my shop notebook running Ubuntu 18.04.1 Easel driver seamed to install, Easel can’t see cnc-machine. UGS can open and control cnc-machine.
I have run sudo adduser “user name” dialout.
Does easel driver have a config file that needs to be edited?

have you downloaded and run UGS?

I would recommend this as a test to see if the port is accessible and “talking” to the controller.

with the Easel Local is a basic Json server but it is also very hard to diagnose as there are no command line for feedback.

with UGS you can run without an install so it is easy to remove if you want.

With UGS you can choose port and Baud rate, as well as send commands and see responses (send commands in Easel but not if you can not tell why you have no connection).

Let us know

Hi Kenneth,

Do you use UGS on the pi or are you running Easel? I can’t get easel to work on the Pi. I tried the https://github.com/samyk/easel-driver instructions but it keeps failing with the npm commands.
Could you point me in the right direction?

I am running Easel Local was well as UGS for larger files that I generate for the laser. I have found that browser based g-code senders have issues with handling larger files.

let me got home and check my settings on the Pi and get back with you.

PM sent to keep thread on subject of OP