Arduiono (no GRBL)

So, have to switch out my arduiono board do to a malfunction . I bought one from inventables and should have everything preloaded ? Pic sender or UGS will not read ( no GRBL) found . I flashed GRBl to it and still no joy, it’s initializing and going through the the motions just not connecting

Thanks in advance for any suggestions

What does this mean? Please provide some details. If you are on Windows, does the Arduino show up in the device manager?

I need to remove it from my device list at times to allow it to reconnect in windows 10

When I go through the initializing phase in picsender , you can hear the slight vibration of the machine or just a slight noise while its connecting.

Yes, it shows up in device manager , when I first hooked it up I didn’t have the promt to install new drivers, when I had issues connecting I deleted and reinstalled drivers /arduiono file hoping to fix the problem

Sorry , I’m very new to these and trying my best to work through it all

I’m not familiar with Picsender.

Can you connect to it with the Arduino IDE serial monitor? Use 115200 baud and change the “end of line” setting to “newline”. If you want to try this. You should see the grbl version number and be able to enter the $$ command to see your grbl parameters.

Went through the steps, switched to new line and sent $$/$ command with no response

In ugs it says connected , when I go to jog , it’s give me an error" gbrl has not finished booting"

Usually that means the wrong connection speed…did you connect at 115200?

Yes , both the port through device manager / arduiono and when selected in picsender /UGS

Thanks for helping

One other thing…you can only connect with one program at a time…make sure everything is shut down except for the one program you are trying.

I’m using task manager to insure the programs are closed before moving between them to trouble shoot .


What version of grbl did you flash? Did you compile and flash through the IDE or use the HEX?

IDE , .9 was the intention , is there a way to check? I have the master folder then unzipped and uploaded to arduiono if that makes sense, followed a forum / YouTube to complete the upload. Honestly I believe this is user error but don’t know how to troubleshoot myself

Thanks again for your help

I would reflash…follow these steps to do it…

Followed that earlier, deleted what I could to re do as you asked , keep getting error messages saying it’s already included

Is the a better way to start from fresh and go through the steps?

If you have already included the library, it’s ok, go ahead and reflash it.

Sorry for my ignorance , but not sure how to reflash

No problem…with the arduino IDE open. look at step 4 of the link I posted earlier:

Open the GrblUpload Arduino example.
Click the File down-down menu, navigate to Examples->Grbl, and select GrblUpload.
Compile and upload Grbl to your Arduino.

1 Like

Well you fixed it! Thank you so much for your help!!
If there any consultation for myself I believe I did these steps at least 7 times today

Thanks for your help, I really appreciate it

1 Like