Automatic spindle control not working

Hi guys,
Not sure if this has been discussed here yet. But I mainly use Vcarve for making files and import the Gcode to easel. When I do this my automatic spindle will not turn on if I use the Z probe. If I dont use the Z probe it will automatically turn on but it turns off on every non cut move and then turns back on again. Long story short. Anyone know why it doesnt work when I use the Z probe. Or how I can get it to turn on and just stay on for the whole cut? I’m using the dewalt 611 router and a 10V relay to control it on and off.

Are you using the post processor that Easel provides for Vectric?

I believe so I’ll double check and see how it goes