Automatic Spindle control


Just a follow up question on automatic Spindle control on there X-Carve. When I first enabled this using easel, the spindle would start when I clicked the “turn on spindle” button.

Now it doesn’t turn on until the x or y axis moves at the start of the carve.

Is this normal behavior? I note the same thing happens (spindle turns on when axis moves) on Openbuilds Control.


1 Like

What’s your $32 setting?


I’m thinking the same thing as Neil here. IF you’ve ever installed a Laser onto this cnc the $32 may still be set to Laser Mode which then will only turn on the spindle during the moves while its at a depth and will shutoff during transitions. . . . Soo IF $32 is set to 1 from a prior laser endeavor you’ll want to set it back to 0 for CNC operations. This is very easy to read and change over in OpenBuilds on the Grbl Settings tab at the top of the screen. :slight_smile: :+1:

1 Like

perfect - changing $32 worked. The machine was second hand when I got it and it never occurred to me this setting may be on - especially since it didn’t exhibit that behavior when I first installed the spindle control.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.