Automatic spindle not working

I had to change grbl from Larry’s version to inventables forked version, and now the automatic spindle will not work, do I have to make any change in grbl

If you went from 1.0c (Larry’s version) to the latest v1.1, your config settings may need to be redone

Thank’s Justin, do you mean the grbl settings, I have altered $100 and $101 and they are working fine but I can’t find a setting for automatic spindle

Yes, GRBL settings. It’s $30 and $31. Easel sets these as $30=1 and $31=0 so that it’s easier to use the output as an on/off.

These are the settings I have so I don’t know why it’s not working, I am using Picsender and I have tried UGCS neither work, it switches on and of in machine set up in Easel okay

You also need to have $32=0 for spindle work. 1.1f/g requires specialized laser G-code usage which is why I don’t recommend 1.1f/g for laser work. It’s dangerous and requires special code in programs that use the laser.

Here are the instructions for using the laser with 1.1f/g.

I don’t recommend 1.1f/g for laser work, it’s fine for spindle work.

1 Like

Manually enter in a M3 S5 command in PicSender and/or UGS to see if the spindle turns on. M5 turns it off.

Have you verified your Gcode has these commands?

Thank you Larry. I have read through that, do I need to download your version of grbl 1.0c first, I can’t find where to download it

Thank you Justin , yes that worked, it turns on and off

It’s available through the link above (.zip files) contains the .hex files

It’s in the .zip files.

There is a link to the version you should try in my response above. Click on the link to get the .hex file unpacked from the .zip file.

Thank’s Larry, I found it now

1 Like

iAll sorted nowmage


Ok, that’s working well. Do you want to continue in this thread or the other one?

Pick one of the threads to continue with and post the $$ output in this thread or the other one.