Axis direction reversed

z axis ok
y and x axis both reversed left button goes right, etc
it did work fine ,I didnt change anything ,
so i tried new usb cable then new gshield and uno board ,wired the same ,still backwards

The machine setup wizard in Easel has a check box to reverse the direction of the axis.
(It resets the direction flag in your controller)

It’s reversed in UGS also ,
And set to inches setting it moves about 4 inches when it should only move 1

I decided to start from scratch
Tried clearing EPROM ,re uploading GRBL . Nothing works

I even tried the x loader and hex file ,still reversed
It wasn’t like this before ,
I spend 3 hours trying to connect to easel ,only to have this
Wiring is still the same ,
Should all 3 green lights be on all the time ?
Mine only come on when it’s moving .

It is normal for the green LEDs to turn on and off as you operate the X-carve.

Post your grbl parameters here (output from the grbl $$ command).

I got nothing ,USB port busy
USB port in the laptop seems too loose so,
I’m going to start from scratch and try another USB port and reinstall the arduino drivers .
Using win 7 , is anyone using Windows 10 for this ?
I really don’t want to do that ,I’m a Linux guy but I couldn’t get easel to work on Linux

Did you run the Easel setup? It will fix this for you. The fix will apply to using UGS also.

1 Like

Which version of Easel Local are you running? version 0.2.3?

If The USB port is busy and your not “connected” then restart Windows,

regards Neal

I do not know if this has anything to do with your problem but if I leave the Xcarve USB plugged into my laptop, if I restart the computer my computer won’t boot up or the machine can not be found. I have to wait till the laptop is booted up with easel ready and looking for the machine. Only then do I plug in the USB and power up the machine. For some reason, I am unable to always leave the USB constantly plugged in. Otherwise Easel can not find the machine.

Don’t know why this is happening, but atleast for my issue I have found a work around. Not the most convenient process but it works.

Don’t know if this is anything like your situation but thought I would share just in case.

Seems fine now ,on other port ,

I think the USB port was bad ,
But it’s weird how a bad port can cause it to react that way

Is the motor still reversed or did you get that fixed as well?

↑ this. Depending how you wired the stepper motors, some bits in the Grbl $3 register may need to be flipped. Easel setup will test the axes and program the register to fix the axis directions if any of them are backwards.

It was a bad USB port on my laptop
Also I’ve learned to boot laptop first then power on
The carve ,then start UGS .
Works great ,I’m really impressed with the accuracy of x carve ,
Once I got the belts to stay tight