Beta Easel Driver Linux support (Debian & Ubuntu)

Today we are announcing experimental Easel Driver support for Linux. We are supporting Debian and Ubuntu distributions on 64-bit architecture.
To install the driver, please download the package file here, and use your distribution package manager to start the installation. For most popular distributions, simply double-clicking on the package will start the installation of the driver along with required dependencies.
If you prefer to install the file using terminal, please run the following command in the folder you downloaded the package:
sudo apt install -y -f ./EaselDriver-0.3.12-x64.deb

Any feedback can be provided in this thread.


Loaded up the deb package on Ubuntu 16.04.4 and when I pushed carve the download box popped up. Screenshot from 2018-06-12 08-43-44

No option for a Linux Download and it appears it doesn’t know I already loaded the drivers.

sounds like you might have installed the drivers but they are not loaded. (running in the background) I would try to execute the command (look at the package file for the executable binary).

When that file is running in the background then the carve button will go green and that message will disappear. that is how this has always acted when making your own Linux Easel local.

Hi DebbieLee,
Thanks for checking out the driver! Can you please try the carving job again? There is no need to restart the computer or browser. Looks like the driver is installed and running but on our end it was marked as out of date, which has been corrected.
The Linux driver will not show up in the download list yet as it is still in the experimental phase. Currently the forum is the only way to get the Linux version.
In case of any further trouble feel free to contact me, I will gladly help you troubleshoot any issues!

1 Like


Hope to get a laptop up and running today, so I can take it to the shop to do some test carves, now that I know the drivers are loading :slight_smile:

Running Ubuntu 18.04 on an old duo core laptop with 2gig ram.

Chrome crashed on the first attempt at toolpaths. Switched to Firefox and everything seemed to work fine.

Second time I just generated the tool paths in chrome and it worked. Out of time today but will try chrome again tomorrow.

1 Like

Just wanted to ask. @KacperMarcisz could you compile this driver for the Raspberry Pi. there are several of us that use them due to the small size and no fans to draw dust into the system. thanks in advance for your consideration on this. and also thanks for finally doing a Linux driver.

Using chrome ubuntu 18.04 . First carve of the day went fine but the second carve thought it was done way early and did not home.

Looks like it lost usb connection machine is asking to home again.

I don’t see an error report from this job. Is it possible you could send me a shared link to this project and I will investigate what could be going on? Thanks!

Hey Kenneth,
That is a very good suggestion. Let me look into this and see what is possible.
Have you tried the Linux x64 driver by any chance?

1 Like

Yes I did and it would not install on the Pi as it was dependent on some X64 packages which are installed but are listed as ARM packages. I can give more details when I get home tonight.

I think there’s a misunderstanding - the driver posted here will only work on laptop or desktop Linux installations, not on Raspberry Pi. What I should have asked is “Did you try the Linux driver on a laptop/desktop”. Sorry for the confusion!

After doing a few tests we were confident enough in the beta to try a couple of customer projects (not that we would recommend everyone do this). Here are the results.

Great Job @KacperMarcisz !


No confusion really. I just wanted to ask if you could compile for the Raspberry Pi architecture, as far as installing on the desktop, it installed and loaded correctly.

Would just really like to see a driver for the little Pi as that is a system that is really great at controlling the X-Carve (small, no fans, plenty of computing power to send the G-code. etc. etc.) I do most of my design work on the desktop in the house and then go to the basement and login to easel and then make sure all looks good then cut.



The sign cut without any issue, short of a toolpath problem I reported via easel. At the end of the cut chrome was slow and had gobbled up memory / hard drive was thrashing and at some point after finishing the carve it disconnected from the xcontroller. When I went to close chrome it crashed.

I was going to just restart the easel driver and give it another shot but I decided to reboot. On first attempt opening easel in chrome it did not connect to the xcontroller. I turned the x-controller off and on again it connected again (no Linux reboot). Which is cool I have never had windows reconnect without rebooting

When I have a few minutes I will give firefox a try and see if it is a little more stable, I find Chrome uses a ton of memory anyway.

Hope this helps.

1 Like

Hey Kacper,

I had another incomplete carve happen. Will message you the project. USB disconnected from X-controller I believe. Firefox everything else the same

EDIT: Just went back the the Easel tab and it has reconnected to the X-Controller.

Seems it is not a project problem. I managed to fix the first one and carve a second without issue.

That being said Firefox was pretty much unresponsive after the second carve. Hard drive thrashing again.

Wondering about stepping back to 16.04 in case 18.04 is still buggy. What do you think?

Hey Steve,
Send me the project if you can in a PM, I will do some digging. Seems like the 2GB is might not be enough for Ubuntu as the recommended minimal value got bumped to 4GB recently (see here, section on GNOME Shell).
I would recommend trying out something more lightweight, like Xubuntu or Lubuntu, instead of downgrading the version. Driver will work fine in these distributions and you will be getting updates more regularly.
I have tried running 18.04 on 2GB of memory and I have noticed the eventual slowdown due to memory restrictions & using swap partition. I am still investigating how it performs under prolonged carves.

1 Like

Great idea!

I will reload tonight and run some tests tomorrow!


Hey Kacper,

Xubuntu 18.04 is much much much better. Thank you for the idea!

I only had time to run 4 small signs and monogram a pocket business card holder yesterday, but did not have any issues,

I have 2 smoked poplar book matched keepsake box lids to carve, I’m pretty confident in your code doing the job are you? :smiley:

I know I know I take my chances with a beta … LOL


1 Like