Inventables Community Forum

Blue carve button

Hi. Okay, first post and I have a problem of course.
For months I’ve been carving fine, the occasional time I have had to shut down Safari and re open when the blue carve button won’t turn green. But apart from that, I’ve had no reason not to have utter faith in my Easel & Xcarve combo. But today…nothing changed from yesterday when everything was fine. The blue Button will not turn green to carve! Arghhh.
I’ve tried everything. I’ve tried Google Chrome, a new USB lead. Different USB ports. Re-installed driver. The leads have not been pulled by mistake. And banging it with a hammer (not really, but opened up XController to check the emergency stop button)
I’ve tried another laptop with windows and the same problem is there.
So what’s the deal? Anyone else had a problem like this, any advice of what I should check?

When I turn on the a controller, there a little jolt on the track moters and the power light (at the rear) is illuminated.

Any help is really appreciated.

Xcontroller? Tried bypassing the front USB connector, and plug into the internal board direct?

Its a MiniUSB inside IIRC.

This indicate PSU is okay and stepper drivers receive power, so its possible there is something acting up on your controller board. My advice, call Inventables Tech Support :slight_smile:

Yes. The X-controller.
Okay, tried the Micro usb straight onto the board bypassing the front. Still the same result, but thanks for the idea, makes sense to rule out some of the obvious faults.

I’ve sent an email to support, looking for a quick resolution as orders were supposed to be cut today. Oh, dear. :frowning: