BobsCNC not responsive after homing

I am running a BobsCNC Evolution 5 machine (this is the Evolution 4 with a bigger work area). This is a GRBL machine.

I am able to connect the GRBL controller to Easel and home the machine without issue. As a sanity check, I manually triggered each of the axis switches and confirmed that Easel shows the switch state changing. All that works great.

However, after homing the machine, I can only jog the machine a few steps before it becomes unresponsive. E.g. I jog X a few times, and then attempt to jog Y and the machine does not respond. At this point, the machine will not respond to any commands from Easel. The only way to get it moving again is to disconnect the USB cable from my computer and reconnect it. Of course, this isn’t much help as then I have to home the machine again and the cycle starts over. For this reason, I have been unable to attempt a cut.

Any ideas where to look to find the problem? My best guess is the controller is getting into an alarm state and becoming unresponsive for safety reasons, but I do not know how to check this hypothesis.

The alarm state theory can be verified over in the machine inspector where you had verified the limit switches… theres a “status” which would show as alarm once it enters alarm state

And in the console area it should include an alarm number that can be used to check the cause of the alarm.

Also you could clear the alarm state by sending a command of $X in the console section.

A common issue that face many new cnc owers is the usb shutting itself off. Youd want to turn off all power saving settings. AND (this is a seperate setting that must be set properly) the USB selective suspend setting must be set to disabled.