Calibration done and ok but cuts are wrong

Hi,

I’ve done the calibration on X, Y and Z axis. They are ok.

But when i cut simple round slots, i get oval strange shape (see picture : https://www.dropbox.com/s/k0968ylmw5jlny4/xcarve-wrong-shape.jpg). Belts are Okay and the machine is square.

I’ve checked my Gcode : everything’s ok (i can tell because on my small Shapeoko 2 everything’s fine).

What do i miss ??

May be tool defelction / loose mechanics or a combinbation of both.
What is the result if you do a 2" wide pocket, using conservative feed rate and very shallow depth of cut (DOC)?
In a softer material?

Yeah that is a odd shape. Have you tried a large circle and square?

If the circle is “tilted” off to one side, kind of lazy ellipse, then that is a symptom of the one of the belts being loose. But those are more up/down ellipses. I am thinking it may be due to bit deflection, gantry twist or loose v wheels somewhere (Z axis maybe?)

I didn’t have ovals but i do have a similar issue with small circles not being accurate.

If the machine is set up right then i would guess tool deflection. Try the circles again but this time do a rough cut first slow the feed to 500mm/min and leave 0.5 to 0.3mm and step down of not more than 1mm. Then come back fit a final cut slow again to the final size.

Looks like you are carving oak. Which is hard so try to be gentle with the cuts and see if you get a better result.

As i said though my small circles are round but always under size.

In all opperations ensure you are conventional milling. I don’t believe an unmodified xcarve can handle climb milling.

There is a post regarding calibration with has a calibration pattern and instructions which is good for diagnosing various issues. I’ll post the link if i find it.

Here have a look at this.

Also check out his you tube channel. It has a lot of good info.

This post right above me that @WayneDollery posted should fix your problems. Take a day and work everything.

I had the same problems with small circles then I slowed down the IPS and it’s perfect I noticed when it’s doing small holes it accelerates to make the loop so fast it’s sloppy I would try slowing things down , also my belts weren’t tensioned enough I bought a fish scale I’m at 4.2 pounds all the way around and I’m cutting nearly perfect circles , my machine is 3 weeks old, I think it’s going to always have a tiny bit of stretch in the belts that’s just the nature of belts so by slowing it down it lets that bit cut better make sure you run the correct rpm some bits need more rpm to cut through the wood some need less…that’s my 2 cents as a new user with the same problem 2 weeks ago …

I’m all good I’m trying to let the OP know he probably needs to slow down as well as check tension , I wasn’t getting lost steps , it was just too fast and stretching getting slightly off circles, as soon as I calibrated everything it was better but small circles still come out funny if the machine is running too fast. Before I could see the belts stretching I was almost 2 pounds under tightened but it wasn’t loosing steps.

Sorry but belts are Okay as i said, and machine is square.

i’m going to try that. thx

One thing that I ran into that contributes to this issue is having your x-axis v-wheels adjustment so tight that you can’t – with the controller powered OFF – fairly easily move the carriage by hand (be sure to do this slowly). You want the adjustment tight enough so that the v-wheels turn when the carriage moves (meaning that they’re contacting the extrusion rail) but just not so tight that the carriage is unnecessarily binding to the rail, making it hard to move the carriage by hand. I ran into this situation having realized that a couple of my v-wheels weren’t turning. To fix, I of course tightened them. Unfortunately, I over-tightened and started seeing my small holes looking like ovals. Prior to that over-tightening, they were spot-on perfect. Unfortunately, after correcting the problem, the holes aren’t quite as perfect – but only because I’ve adjusted the v-wheels enough to be sure they all contact the rails. I’m guessing that I probably need to up the juice a bit on my x-stepper.

Hi Robert, if that was the cas i would not have the default at the same place on the mouvement it should be random. In my case it is at the same place

hi @bdubu, you were right, it was the V-Wheels that were too tight + we decreased the x-motor tension a little bit and everythings fine now ! Thank you all for your help & ideas.

Excellent, I’m glad it worked out!