Calibration help please - I'm lost

Ok, So I’ve been fiddling around with the x-carve for a couple of weeks. (My schedule doesn’t allow much during the week, but on the weekends I get some fiddle time).

I find that calibrating using calipers without cutting and cutting and measuring a cut square give two different results. Is this normal?

With Calipers I screw them to the waste board put the end mill in the jaws, and then command moves and monitor the results. I do this for x and y. It’s reasonably accurate this way and I get some errors but they average out.

Then I tried to cut a 50mm square 6mm deep in MDF. To eliminate any other software issues I generated the g-code using Inkscape and gcodetools, then checked in CAMotics that I was in fact getting 50mm square. I used really conservative feed of 400mm/min so as not to put too much strain on the machine.

Using this method I measured the square being cut both inside and outside, calculated the tool width from the difference, then calculated the distance of center to center of the cut to find the square is undersized! (0.2mm in x, and 0.25 in y*)

(the square has different length y sides too (49.76 & 49.69) but I may need to work a bit harder on squaring the machine for that one and I think I know what to do there).

But the real question is should I update the steps per mm based on the cut square or is should the movement without cutting distance and cutting distances be the same and there is something else wrong?

You could be losing steps under load, or you may just need to adjust the steps/mm.

Take a look at these videos:

Thanks for the suggestion.
I have tried the procedure in Robert’s video. It helped a lot for me to understand how to do it. I also used a multi-meter to set them all the same.

By the way, the controller is a CNC shield rather than the g-shield. I set the voltages to 1.4 volts on the drivers which seemed to be a bit below where I could hear the motors cut out on the high end and well away from where they cut out on the low end. The motors themselves are hot to the touch. - All the same perhaps I better knock them back a touch.

I was looking at the test piece again and compared it to the g-code. I thought there was a little bit in the g-code the plunge the endmill a little off the path then cut into the path. However the g-code doesn’t have this. The square has a visible point outside the path where the endmill plunges then the square starts a little bit away from the the plunge location.

The direction is “conventional milling”

What could this mean? is the endmill being pulled towards the center of the square? Is it a flexing problem? It would explain the difference between the two calibration methods? Most importantly, how do I fix it?

I’d post pictures but not sure how,… ahh found it :wink:

You would need to check the specifications for the driver chips on your controller to see what the appropriate reference voltage would be.

Stepper motors do tend to run hot. Check the current rating on your motors.

If you are using the Pololu stepper drivers, they tend to be under-current for the X-carve. Depends on which motors you have.

Maybe someone else can help out with the corner issue.

Just something to check, make sure that your $1 grbl parameter is set to 255 ($1=255).

Because gcode is trying to create internal path sharp corners. What software you’re preparing to generate g code?
Example; Vcarve have option for sharp corners inside the path or outside the path. If you don’t want to drill that hole at the beginning, you have to change your starting point to some where on middle of the cutting line by inserting extra vector and tell that is your starting point. Corner starting points are little tricky.
Also you didn’t mention how do you want to cut, outside/inside/on ? If it is outside cut (that’s more likely as shown) this is normal.

LarryM, the motors should handle the max current from the drivers. (NMEA23’s), I’ll need to check the specs directly but I remember when I looked they were approximately the same. But it certainly is the Pololu drivers.

$1 is set to 255 (which means the motors hold steady when not moving and I can’t push it around. This was the mode I used to check the drive current, apparently this is the highest current draw. Is that right?

HI Alan,
I used gcodetools to make the square. The gcode does not have deviation in it, so it looks like it’s a mechanical issue. What threw me originally is that Fusion 360 does do this with the toolpath. The point of using gcode tools though was to remove all of that from the equation.

Here is a screen shot of what CAMotics shows me.


The NEMA 23 stepper motors that Inventables sells can operate up to 2.8 amps per phase.

The Pololu stepper motor drivers (A4988 Black version) is rated at a maximum current of 2 amps per phase with sufficient cooling. That drops down to about 1.2 - 1.4 amps per phase with just a cooling fan.

The (DRV8825) version is rated at 2.5 amps per phase down graded to 2.2 amps per phase by the current sense resistors. Without additional cooling it is really limited to about 1.5 amps per phase.

The gShield is rate for 2.5 amps per phase with adequate cooling (what does that mean?). Anyway, I have run them as high a 2.0 amps per phase without issues.


First, thanks for taking the time to reply.

Ok, the stepper motors supplied with my x carve look like they are good for 1.5A. The label says

57BYGH51 402A
1.8” 1.5A 1N. m"

Details linked

The CNC sheild came with pololu DRV8825 Driver which I dialed to 1.4V vref which means the current limit is set to 2.8A?? I guess this isn’t possible according to the datasheet, hmmm I’m going to have to look into that some more. They are fan cooled with heatsinks.

I guess the important point is that I had the motors in holding mode and changed the current limit pot until the drivers shut down, then backed them off until it could set there for 5 mins with no shut down. I measured the vref to be 1.6V (If I remember right), and then backed them off to 1.4. I think perhaps though I need to look at this again because the vref and max current the chip can put out doesn’t make sense to me any more. Additionally the vendor had something in the documentation that the steppers were good for the full current.

So I guess potentially the steppers are not holding strong enough? - is that where we are going?

Off to review the documentation …

Ok so just an update. I tightened the belts to 3.5 lbs when i pull the belts to 1 inch. This improved things somewhat. I tried also the option in fusion for roughing and finishing cuts on the profile. I dont know it it helped much but the result was good so I’ll stick with it for now.

The x axis is still a little under sized when cutting. But I’ll live with it for now.

Im considering some stiffening mods in the near future also.

Take a look at this: