Calibration of X-axis

Calibrating the newly built X-Carve and having an issue with the X-axis.
When I run the calibration moving the axis with the arrow buttons manually, the y and z axis move correctly and consistently in the direction one would expect. When I push x axis button, no matter which arrow button I press, I get the same result. The first press the X-axis motor usually moves the correct direction but the second press of the same button moves the the x-axis motor in the opposite direction, third press correct direction, fourth press opposite direction, etc… Each button press (of either button) moves the x-axis the reverse direction of the previous press. This seems strange and I couldn’t find anything similar in the forum troubleshooting section.
X-Carve 500mm
NEMA 17 motors

Sounds like a loose connection…check your wiring.

ah ha
found the x-axis red wire on the gShield was loose
tighted it up and it works :slight_smile:



Thank you… setting up my X-Carve. This solved my issue on the X-Axis.