Can Easel be used on a Shapeoko3

Can Easel be used on a Shapeoko3?

Thanks

Hi @GlennMDutcher,

Easel has been designed to work with X-Carve, Carvey, and Shapeoko 1 & 2. Shapeoko 3 is not an Inventables product and we haven’t tested it with Easel. If your machine doesn’t communicate with Easel, you can still use Easel for design and export your g-code to another application like UGS.

1 Like

I just got a Shapeoko 3 and am trying to use Easel. It appears to cut the x and y axis correctly, but the z axis cuts about 3 times the set depth. Anyone know how to correct theis? Someone posted that we could design in Easel and export to UGS, but there is no “Export” feature on Easel, tell me how.
Thanks, Doug

Hi @DouglasTodd, you can export g-code from Easel by going to MachineAdvancedGenerate g-code.

(By the way, we haven’t done any testing with a Shapeoko 3, but based on your description I’d be pretty surprised if Easel’s g-code or machine control was the problem. Have you tested the Z-axis with other software? For example, does it jog the right distance? My suspicion is that your Z steps/mm value isn’t set correctly.)

Hi, thanks for the quick response. I haven’t tried another software, but will shortly. How do I adjust the z steps/mm?
thanks, Doug

Thanks, but that isn’t the main problem with the z-axis. When cutting, each pass the z-axis drops about 1/4" instead of 1/64". How do I adjust that? By the time the project is cut, the cutter has gone 3 times the set depth.

OK, I used Universal g-code sender to move the z-axis by 12mm. It actually moved 56.169mm. Then I used your formula.
Current steps/mm was 188.947 which made the new steps/mm 83.602. Then I entered $122=83.602 in the machine’s inspector console, and went to the carve of a piece. The result was that the start of the cut instead of being at x=1 and y=1, it moved to a spot about 12inches away from y start and 8 from x start, but when cutting, z still dropped about 1/4" per pass. I guess I’m lost and need help
Sorry for the bother, Doug

Ok, I redid the whole operation. Starting step/mm is 188.947 Set travel is 15mm Actual travel is 70.109 making the new step/mm of 40.428 I changed the code to $122=40.428 and got the same result as before. The x and y axis did not start where they were supposed top and the z axis moves done 1/4" per pass

I put everything back to the starting positions before this last go round

I lknow and can’t understand why the x and y moved

yes, i left it for awhile and came back to it so it was restarted

ok

ok, did the up and down test 4 times and got a set travel of 15mm but actual travel of 70.281mm
I don’t know what you mean by micro stepping setting and drive setup
New to this

Got the machine working properly (works when you use the right code). It cuts great and I have akready made my first project. Thanks evryone for all the help, Doug

1 Like

102

1 Like

I’ll post some of them as soon as I get a dust shield for the machine.

Can you please reply with the codes you used to get your XXL to cut from Easel properly?
Thank you!

@KevanKjar You can export the gcode from Easel and send it with any sender. Any reason you want to use Easel to send? Have you tried just setting as a Shapeoko?

1 Like

@KevanKjar

I am pretty sure Easel can communicate directly with the S3 as it is GRBL/Ardunio based just like the Xcarve.
You will need to calibrate the following:

  • Microstep setting, refer to S3 manual for suggested starting point
  • Step per millimetre for each axis, GRBL parameter is $100/101/102 for X/Y/Z
    You test each axis by jogging them 10mm each, and measure the actual travel vs commanded distance. This forms the basis for fine-tuning these three values.
2 Likes

Thanks guys; I have not tried sending direct to XXL so your advice is just what I’m looking for. I’m a longtime woodworker and a NUBEE with this cnc stuff. Thank you for helping me along. I really like the ease of Easel and especially the project library to pick from and USE. Its a huge aid for us NUBEEs. I’m now working on following Haldor’s advice and get XXL to run from Easel.