Can´t connect arduino

Hi, i have been trying for hours now and im starting to lose my mind here. I got a new computer now with windows 10 and i cant connect to the arduino. First i downloaded the arduino softwear and tried to connect by finding the arduino.inf file and connect to the board. but there where nowear to be found. Starting to read about it and saw that i needed a older version. downloaded a older version but cant see the arduino uno showing up on the ports either. When i plug in the usb cabel from the x-carve, it just say (unknown usb device). Hope you guys understand my problem and can be helping me what i have missed.
Thanks for answear/Aron

Not sure if this has been done yet:

https://inventables.desk.com/customer/portal/articles/2601372?b_id=9562&t=0

i don´t have the x-controller. i bought my x-carve 2015 and the x-controller wear not on the list that time.

under the windows link in the instructions at http://x-carve-instructions.inventables.com/xcarve2015/step16/

you know if you just post the link to the file they will never learn to look for it.

that is why I posted with the link to the instructions page that links to the file they need. in the future they will be more likely to remember how they got there.

1 Like

Not everyone wants to be an internet archeologist, some people just want the answers with the fewest steps posssible.

No intent to upstage, just adding value I’d want if I were the OP

1 Like

i have read it many times but when i come to (look under ports) i don´t find the Arduino uno and then i search for Andruino.inf like they say on the next step but i can´t find that either.

looks like he needs more food for thought. glad you have the spoon.

Just messing with you @JeremySimmons could not help myself. :slight_smile:

how do you mean by 2 profiles? i have worked with another computer before but it is about to crash so i got a new one now and im trying to get it all started again. I have installed arduino on the computer but when i look under ports i can´t find The (Arduino uno) port. So i go to the next step like they say on the instructions but there i can´t find the arduino.inf file. Is it the version on the arduino program or what is wrong? What version do you have?

I thought you already knew @PhilJohnson I have my work account and my home account. I liked the X-Carve system so much that I also got one for the class I teach.

1 Like

it has been awhile since I have had the older controller but it sounds like you need to install the driver manually as outlined in the directions. it states that there should be a file called arduino.inf in the drivers folder inside the file you downloaded. if not then there is a problem with your download. go to the link and download the windows file as indicated and then extract the contents of that file to your drive and note where you extracted them (example on your desktop). you should now have a new folder on your desktop with all the extracted files in it. open that folder and there should be a folder called drivers, open that folder and there should be a file called arduino.inf that is the file you are looking for.

once you get the drivers loaded you can try to connect with easel, if you are still having problems connecting then open the arduino software and use that to connect. you can select the port and make sure the baud rate is 115200 and see if that connects. let us know.

To help the guy out… :wink:

I suggest a visit to the Arduino.cc site and get your Arduino board connecting with your PC before you do anything else. It sounds like a driver/USB issue.

1 Like

you mean like it is described in the instructions? that has been exactly what I have been pointing to also. but at some point he is going to have to follow the directions as listed on the assembly page.

I always tell my students that struggle with these things to do them three times. Once for familiarization once for comprehension and once to make sure they got it right. it seems odd at first but by the third time comprehension sets in and the get that epiphany look like “wow why did I not get this before”.

1 Like

Ha. I have to do all my woodworkings 3 times for the same reason…gets expensive too. :frowning:

1 Like

can say much, how do you think I know about it. many times I had to learn the hard way.

1 Like

@AronGustafsson did you get the drivers downloaded and installed?

What version of the Arduino IDE did you install?

The INF file should be located in a “Drivers” folder under the folder location that the Arduino IDE was installed to. I want to say it is a folder immediately under C:.

I suggest doing a Windows search for “arduino*.inf” (leave that * in there) and see if it finds the file (or the “Arduino UNO.inf” file). If so, right click on the file and choose “Install” then reboot your PC. It may take unplug and replug of the device.