Inventables Community Forum

Can’t get blue button to turn green

I am having problems getting easel to work on my Chinese cncest .
The control box has a 25 pin parallel port and the same on my windows 7 laptop , I can work on mach3 but I think easel would be easier for me to use.
Tried using a printer 25 pin adapter to usb cable but still not working and have tried the same on my Mac computer.
Could it possibly be that a need a UC100 parallel port to USB adapter to get it to work.

Easel can make the gcode, but you’d need to export it (Project>Download Gcode)
But you need to use a mach3 sender in order to send the easel file as it cannot send to mach3 machine, there are extra lines of code needed that are added within mach that easel will not add in…

OR change your controller board to a grbl one (about $30)

Could you please recommend a grbl board for me that could get me going with easel as I’ve no experience in this field.
I’m almost 70 so I’m sure sure you understand.
Many thanks

Buy the Inventables X controller if you can afford it. Once assembled it is plug and play. It also has an emergency stop that some others don’t have. Right there that feature is worth the extra hundred bucks.

I have another router with mach and uc100 too. I am using the Universal Gcode Sender with the X controller and although it is a bit simpler than Mach, I use the same features. The only tricky part was getting the two software pieces to work, and that was more an installation issue than anything else. The 2 software programs are in the installation and set up instructions. You have to download them and then “extract” them, like a zipped file of old.

Being able to use a new computer is a plus. I have a bunch of old windows 7 ones that were just unreliable. If it helps… I’m on the far end of 60’s so I get where you are coming from :-). These younger folks never had the pleasure of trying to do something with a Commodore 64 or Timex Sinclair computer…LOL.