Can we mill a 2mm thick aluminium on X carve

Recently i tried milling a 2mm thick piece of aluminium. Once the carving process starts, the spindle goes slightly up and when it comes down, it stays about 2mm above the surface of the material and starts moving along the tool path. I have tried many times, but it always acts in the same way.

Any help on this will be greatly appreciated.

This must be a problem in your gcode being sent to the machine. Sounds like either your z zero is not set correctly or your depth of cut is not set correctly in your design software.

When you start the actual cutting part of your project, the bit will raise and then move to the starting point of your first cut. Then it should lower to the depth of cut you specified in your design. It will raise and lower multiple times usually depending on the complexity of your design. If it is not lowering enough to actually cut the material then you probably have something wrong in your design. If your design is correct then your should check the method you use to set your z axis to zero prior to starting the cut. At Z-Zero, you bit should be touching the material to cut and your z position indicator should be reset so it reads 0.000.

Dear Charley,

Thank you so much for your help, but every thing is working perfectly within easel. My z zero is also okay, bit is just touching the material at z zero. It is just that when i select aluminium as material within easel, it initially shows a thickness as 6.8mm. There i am changing the thickness of material as 2mm and saving it only to face the same issue.

But when i mounted my 2mm alu on 5 mm MDF board and made the thickness as 7mm in easel, It worked.

Here i kept cut depth as 2mm in order to make a pocket.

I guess it has something to do with the predefined thickness setting for every particular material (Just a wild guess)

When i select MDF as option and change the thickness to 5 mm from default value, that is also working perfectly.

It is just this aluminium case that is causing issue.

Can’t understand what’s causing the issue.

It would appear that you are setting your Z 0 to the surface of your waste board then putting in a 5mm waste board and your 2mm metal. This mean that all of your Z moves are positive moves.
If you set the top of the metal at Z 0 then all your Z moves have to be negative moves.

Take a look at your Gcode and see if the Z moves are + or - . In the first case they have to be + in the 2nd case they have to be -

Hope this helps


I don’t use Easel so I can’t offer any experienced advice. I do however believe that in Easel, you can select any material you like within Easel and it will load predetermined default values for cutting. That doesn’t mean you have to cut that material, you are just telling Easel you are.

In other words, you can tell easel you are cutting 3/4 inch MDF when you are actually cutting 2mm aluminum. The important thing is that you tell it what depth you are cutting and where z zero is. If you want to use 1/2 inch MDF as a waste board on top of your x-carve waste board that is perfectly fine and easel doesn’t need to know that. All it really needs to know is where the z zero position is. Once you have set your z zero then you can adjust you cutting parameters as needed.

The benefit of selecting one of the available materials in easel is that they have already set what they feel are good cutting feeds and speeds but you can adjust them as you see fit.

Hi, Charley

I was a little busy from past few days so couldn’t respond.

I have tried everything but the machine still behaves in the same manner as it was earlier.

When i place a 2mm alu and make thickness as 2mm in material selection section of easel. It should simply cut it but the spindle first moves up from the top of the material----> then comes down-----> but not all the way to the surface of material—> it just stops say at about the same height (i.e. thickness of stock) and starts moving along the tool path.

I tried using UGS (universal g code sender) to send G code but i am facing another problem there.

When i hit send the machine moves all the way to front left corner–> as it hits the Y axis end stop it doesn’t stop and keeps pushing to move ahead. Although the all the endstops are working perfectly when i use easel.

If this problem can be solved with UGS, atleast i can check weather the issue I am facing with easel (i,e, of thickness persists with UGS or not).

That sounds like it could be a zeroing issue.
Are you manualy setting your home location on your material before sending your file?
Not just height but all axis?
Also confirm that you are using the same home location as is set up in your cam software.
Default is usually lower left hand corner, though most software will let you define any corner or center of material as 0,0,0.
You also may want to take a look at what post processor settings you are using to make sure it is using the correct units (mm vs inch), it is in the correct mode (absolute vs relative) and that it is working off of material zero not the machine zero.

Try watching this video and check your machine to insure that it is moving the correct distance. This may help.