Cannot carve with vcarve

So being new to this, I’m still trying to figure what is going on and what went wrong. I did a few projects with easel and got confident and decided to dig into vcarve pro. I had a coupe of files I purchased, went through set up the tool paths then could not figure how to get it to ugs. Finally just created a file on desktop then was able to find it and opened it in g code. Immediately went to port 4 and had to change baud to last number to get it to work in order for it to talk to xcarve. Took me a day to figure that part out. Opened file and set the bit to corner of piece and then hit send. Bit raised and moved to start, kind of acted like it was carving but was in air and then alarmed and said null. Tried to figure out what I did, but was clueless. So I tried a basic clipart and I did same thing again. This time it acted like was going to carve but didn’t. Just acted like it was having seizure. Oh I couldn’t get to stop, so just hit power button. Weird thing z belt broke. I cannot figure out what is going on. I tried UGS 2 and i load tool paths but has no lines.and cannot get1.8 to load. Wondering if wireless is affecting it. Weird it works fine withe easel.

I think your Toolpath have something wrong. When you finish drawing in Vcarve, you have to go Toolpath screen, choose you carving options, like Pocket-Cut-drill ETC. while youre doing it tool must be choosing for the operation. .125 spiral-straight…ETC. edit your tool change your feedrate, plunch rate. All this explained on Vectric tutorial videos. You can’t send toolpath to UGS blindly. Just go back to tutorial, watch carefully. Carving strategy is not auto. You must choose.

Be sure you have loaded the post processors for X-carve and you select that post processor when you save the tool path

I actually chose tool paths 3d tool paths set tool paths. I will watch video again though. Something just seem wrong.

what post processor are you using?

Just try to master 2d first before jumping further. You’ll be alright. This is learning curve. We all go true this.

I downloaded xcarve processors. Practice, practice


So I’ve followed tutorial videos tried basic carving , skipping 3d and cannot get vcarve to carve right. As soon as I send it to gcode, it screws up. I’ve tr all three versions and carves up in the air, or right through work piece, or way off work piece. Each version did it different. Had no problems with easel…

I use VCarve almost every day, creating drawings then saving gcode using the correct post processor. I have had no issues with any of the gcode produced by VCarve, but I made sure I used the correct post processor and, in fact, made a few modifications to the PP for my Shapeoko 2 system which is essentially the same as an X-Carve. I’ve used UGS 1.0.8 mostly - UGS 2.0 has some issues like not showing line counts. The bottom line is that following all the right steps gets you what you want if your cnc is working right.

I say all this to assure you that you don’t have a VCarve issue if you’re using it correctly.

@BillArnold is correct - Vcarve works great with the X-Carve. I use Vcarve every day with no issues (using the “X_Carve (inch)” post processor" unmodified.

If you use that post processor and your machine is not executing the gcode correctly you need be sure you have the correct version of UGS and the correct software version loaded for Grbl (.9i or .9j)

Got it working using thr grbl post processer found right vcarve pro

1 Like