Cannot connect 3018 Pro to Easle

I just finished assembling my 3018 pro, I have installed Easle and
I am trying to install my machine, I got to the screen asking for machine details,
I plug in all the details and click “confirm setting”. I then get the “connecting to other
(grbl)…” screen” then nothing happens.

I tried the following:

Verified com port

Verified the driver (CH430) showed up in device manager.

Changed the driver baud rate from 9600 to 150200.

Rebooted the laptop and reset the 3018 several times.

I connected the 3018 to a simple serial program and was able to communicate with it.

I can use the controller that came with the machine to test rotation and movement, it does work okay.

After a few hours of trying, I downloaded UGS and it worked okay on the first try. I was
Able to connect to the 3018 and nudge it, and run other tests.

I would like to stay with Easle, can anyone offer a suggestion to solve this problem.

I am in exactly the same spot as you…

If the machine works with UGS, just save the gcode from Easel and run it from UGS? You can design in Easel. You can output the gcode in easel to a computer. You can run UGS with that gcode. I don’t use easel, but I run my x carve with UGS and Gcode I create from other programs.

Thanks for the response. I will go with your suggestion,

Is that a typo? Did you mean CH340? I have a 3018 Pro as well and I’m getting ready to try Easel as soon as I get some free time…

Yes, it’s a typo, thanks for noticing. Should be 340