Cannot get UGS to connect to X-Controller (among other issues)

Decided to start using my X-Carve again after a long hiatus (had a kid). Before the kid was born I bought the X-Controller upgrade. I hooked it up the other day and am now running into a host of problems, I’ll try to separate them out, but someone should really do an end-to-end software setup for folks that want to do more than just stencil art in Easel (just say’in).

ISSUE #1 - Can’t connect using UGS

First things first:

  1. I did use Easel to connect to the machine X-Controller and went through the configuration steps
  2. I have downloaded every IDE and driver in the book.
  3. Machine worked fine with g-shield and Arduino board.
  4. Setting up Chillipeppr + JSON server works (more on this later)

All the components that I can tell that are involved in getting a computer set up on the X-Controller:

  • G-Code sender of some form
  • Drivers to recognize the X-Controller board (not Arduino based?)
  • GRBL software on the X-Controller board to translate GCode to machine movements

Laptop and Software:

  • Surface book 2
  • Windows 10 (latest updates)

So, for the issue(s). I have tried to connect both the Platform and Classic versions of UGS to the X-Controller using the cable that was supplied with the X-Controller. Serial Ports are never recognized. I have installed the FTDI drivers, I have installed the latest Arduino IDE which includes Arduino drivers. When I turn on the X-Controller and plug the cable into my laptop, it recognizes a device change in device manager and shows a new COM component. Any attempt to point that device to a new driver fails to update the standard USB driver for the device. For some reason I can’t pick a specific driver file in Windows 10, only a directory to search. Any time I try to open UGS classic 2.0 it says no serial ports found. Any time I try to open UGS platform 2.0 it is always in a disconnected state. I have tried to manually set the port to COM3 with the 115K baud rate, but nothing is ever recognized.

If anyone has experience getting UGS to run with the X-Controller I’d love to hear the steps you used to get it running.

ISSUE #2 - Grid is now in negative space

When I connect to the machine using Chilipeppr and run a homing command ($H) the home position is always deep in the negative plane. It seems that the new X-Controller thinks that home is in the upper right hand corner of the machine. I don’t really want to switch all my homing switches around to make this work. Is there a way to set up the machine so the “bottom” left hand corner is 0,0 and make all movements in the positive quadrant plane? This would make life a lot easier…

Thanks all.

By default, GRBL machines have their home in the back right. Homing defines your MACHINE zero. You need to set your WORK zero. Regardless of sender, you can do this by jogging to where you want zero to be and sending a G10L20X0Y0Z0 to set Z-zero for all three axes.
As far as the UGS connection issue… Make sure you don’t have anything else open that might be trying to connect (Easel, chillipepr, Arduino, etc). The baud rate should be 115200. Beyond that, it might be a UGS thing. Try CNCjs.

Thanks for the response. I tried sending the G10 command this afternoon in chilipeppr and it came back with an invalid code error which was odd. Will give CNCjs a look; thanks for the response.

Get screenshots when these things happen…it helps to diagnose quite a bit.

Which version of chilipeppr are you using? Link?