Inventables Community Forum

Can't connect my cnc to Easel

I need help please, I have been using easel software on my cnc for a while now, but suddenly it isn’t working anymore. The machine is not being seen by my computer. I have tried to follow all the help guidelines and have reinstalled the software but the “carve” button takes me back to the troubleshooter and wants me to install the software again. I followed the help guidance but still have the same problem. I have seen others with what seems to be a similar problem, but reading through their posts and comparing with what I have tried, and even trying to uninstall / reinstall the easel software and different versions of the software hasn’t worked. Any help will be appreciated thanks

Is you machine an X Carve?
If so are you sure the power is on, the panic button is pulled up?

It was my anti-virus that was causing problems and I have managed to sort it out now and the x-carve is working well

1 Like

Same problem please post solution to correct this.

Same problem here. The message “Machine must be plugged in and turned on to jog" keeps popping up although I tried every solution in the FAQ. Inventables support is sending me a standard mail with some solutions that are also in the FAQ.

I managed to get easel running by taking down all security measures as in the FAQ ( fire wall , ports virus scanner etc.) and install the easel driver under this conditions. After this I restored all security measures exept chrome save browsing.