Can't connect my new X-Carve for Machine Set-up

Hi there,

Just finished assembling my brand new XCarve (1000x1000) and Dedicated Computer, but I just can’t get through the Machine Setup Step.

I have tried all what is written in the forum but still no results.
The device is recognized in the computer under Arduino Uno (COM 3), I uploaded the grbl-09j.hex provided by inventables through XLoader and uploaded/compiled grbl library in arduino software. What I still get is a blunt “Plug in your USB cable and turn on the machine” by Easel.

The computer is assembled by myslef, mainly :

  • ASUS Z97A motherboard
  • Inter Core i7 4ghz
  • 16 Gb RAM
  • VGA Card AMD Saphire 4Gb
  • Windows 7 Ultimate SP1

Not being lazy, I tried the same on my DELL computer on Window 7 and still no results.

Please help, can’t wait to start the machine, knowing that that I had trouble getting it all together due to late shipment of missing parts (I am in Morocco).

You could look into this to see if this is your issue:

If you have a powered USB hub, try that as well. If you don’t have one handy, try unplugging as many non-critical USB devices…leave only the mouse and arduino USB’s plugged in.

Can you please post the connection diagnostic info in Easel after clicking the blue “Carve” button? (see below screenshot)

It should look something like:

{“comName”:"/dev/cu.Bluetooth-Incoming-Port",“manufacturer”:"",“serialNumber”:"",“pnpId”:"",“locationId”:"",“vendorId”:"",“productId”:""}
{“comName”:"/dev/cu.usbmodem1411",“manufacturer”:“Arduino (www.arduino.cc)”,“serialNumber”:“A4132373935351A06121”,“pnpId”:"",“locationId”:“0x14100000”,“vendorId”:“0x2341”,“productId”:“0x0043”}

Well, Thanks all for your prompt contributions.
Here i where i am, little progress (I donno if yet it is…):

  • Deleted Easel Local 0.2.3 and went back installing the 0.2.2 version, it made a little progress. Though, please note that Easel Local never finishes installing… I am always obliged to force it to end through task manager, it always stucks at “verifying intallation”. I read that it doesn’t matter because of the nodejs module that is preintalled (through java). I just made sure to have the nodejs intalled also in the c:\EaselLocal and that nssm guide has the right path to node.exe and its folder.

  • Now I get this

  • Used a powered USB hub (screen) and using only minimum necessary USB plugs (mouse and keyboard), still getting ame result.

  • EricDobroveanu, where I can access to the page you are showing?

Eric, I get this:

With regards to Easel Local installation, it is stuck like this

it gives finally when back to Easel 0.2.3 the following ;

{“comName”:“COM3”,“manufacturer”:“Arduino Srl (www.arduino.org)”,“serialNumber”:"",“pnpId”:“USB\VID_2A03&PID_0043\75439313737351215252”,“locationId”:"",“vendorId”:"",“productId”:""}
{“comName”:“COM1”,“manufacturer”:"(Standard port types)",“serialNumber”:"",“pnpId”:“ACPI\PNP0501\1”,“locationId”:"",“vendorId”:"",“productId”:""}