Can't get commands to work for JTech laser

Just installed JTech laser and can’t get the M03 or M05 commands to work.

I don’t have X-Contoller, I can get the laser to turn on manually by flipping the spindle switch in my power supply, or switching the jtech driver to CW mode. Besides that I cannot get any commands to work for the laser.

Here is the GRBL I am using Xcarve_JTech_grbl - latest release (9/1/2017)

1 part that confused me in the install is this part,

I don’t have the yellow or black wires there…

The JTech instructions are bypassing the “spindle” switch.

The black and yellow wires referred to are just to the left of your hand in the picture. You use the yellow and black wires coming from the connector that has the homing switch inputs in it. That connection is the PWM output that controls either spindle speed or laser power level.

If the switch to the left of your hand turns the laser on then you have the laser hooked up correctly.

If you put the black/yellow wires to the left of your hand into the “spindle” green connector that is in front of your finger then you should have Arduino control of the laser with the switch in the “logic” position. Black goes to “Gnd” Yellow goes to “logic”.

If you also have a PWM controlled spindle it gets a little more complicated.

That is the picture from the instructions so mine looks a little different :slight_smile:

I don’t even have that string of connectors hooked to my board.

So if I’m gathering this correct I need a couple connectors to run for pin 11 and 14 … hook those into the green connector and should be good to go

I think so, but without seeing your setup, hard to tell.

I was able to get some connectors soldered in, I’ll give it a try here shortly and if I’m still having issues I’ll post some photos of my setup. Thanks,

-Edit , Was able to get to work with splicing the yellow and black with the red and red/black

Still no luck with arduino control of laser, here are a few pictures of my setup

1 Like

I didn’t have the wiring correct to have the arduino control the laser, was only able to manually start the laser. All good now.


Since you are using PicSender, let me help you with your settings. If you haven’t upgraded to PicSender 2.7.9, now is a good time to do it.

Put these files, which are edited to fit your system, in the following directory: (over write the ones that are there)
Laser.txt (1009 Bytes)
Spindle.txt (1.1 KB)

  1. Launch PicSender, Press the “Open” button
  2. press the gold “GRBL” button at the top of the screen
  3. check “Use Auto Settings”
  4. press the gold “Return” button at the top of the screen

Now you are set up so that you can switch between laser and spindle with optimized settings for each task by just selecting the appropriate button on the startup page (either “spindle” or “laser”).

If you use a different sender program, other than PicSender, make sure that you leave PicSender with the spindle/laser selection set up for the job you are going to do next.

More information is available here.
Xcarve_JTech_grbl integration with PicSender. ( Instructions )


Thanks Larry you have been a ton of help… I’ve got it up and running, still working on some feeds and powers but my wife wanted the Dr. Evil “activate the laser” for a picture so here is what I’ve got so far!


Looks great. You’re a pro!

1 Like

Hey quick question, everything seemed to be running just fine with the files i was producing, i took a break, now i come back and for some reason at the beginning of my engravings my Z is moving, like down .5"

Only change is I tried running Phil’s power test file, saw the Z was moving so i stopped and tried to make my own , now my Z keeps moving on my files

my material setup in vectric

heres first few lines of a gcode

M03 S0
G1X0.6798Y0.2963F40.0 S170M3
G1X0.6947Y0.3196 S170
G1X0.7001Y0.3307 S170
G1X0.5801Y0.2107 S170

Probably not your current problem, but I would recommend that you go to the page where you downloaded my version of grbl and pick up the post processors for Vectric products that are posted there.


@LarryM I’m having the same issue only with the X-Controller. I’m able to create gcode in PE6 and run it in PS. I haven’t been able to get M03 SXXX to turn in he laser for focusing. I’m sure it’s because I have missed something only I don’t know what it is. Please ObioneconLarry. Your my only hope.

What a hoot. LOL.

What version of grbl are you using?


Ok, that might be part of the problem.

If you don’t need spindle speed or feed rate over-ride then I suggest you load this version of grbl on your machine. Since you are using PEP6 load in the version with the 1ms Dwell.

If you use Vectric products go ahead and pick up the post processors that are available on that page.

We can make 1.1f work if you need those functions.


I have a machine dedicated for the laser. I don’t need any of the spindle functions. So I’ll give that a try and let you know. Thanks.

That’s what I needed. You the man (or should I call you Jedi Master) Larry. Also. Is there a way to setup homing switches without a Z axis?

Should have went with Jedi GRBL in he first place.

Grbl does allow modification of the homing cycle. It is a compile time option, so to change the sequence (eliminate Z) you would have to modify grbl and rebuild it.

That’s what I thought. Way above my pay grade. Thanks @LarryM. Top notch as usual.