Can't get g-code import to work

I’m just about to the limit on my patience with this. I’ve read everything I can find and nothing seems to be working. I have a simple little block model in Fusion 360, it’s a 5"x9" block with a few holes in it. When I generate the toolpath and PP, no matter what I do, or what I change when I pull it into easel, it’s always out of the limits.

I’ve tried changing the offsets, reducing the size, etc. I always end up with the same result.

Would appreciate any help. I’m pretty new to 360 and certainly to inventables, so i’m kind of fumbling my way through, but this is a complete stopping point for me and all the documentation that I can find is a couple examples of everything working perfectly. :-/

@Ts1, Hope this helps.

EDIT: Uploaded video not working…see youtube link a few comments down.

this is EXACTLY what I needed. Thank you so much! So much frustration. I think it would be a nice feature to have for easel in general if an imported file failed to give some kind of graphic overlay with the error to show where it went out of parameter. looking at the code lines isn’t very descriptive, especially when it’s 5k deep.

Thank you again for helping out!

1 Like

@NeilFerreri1 I can’t get the video to load. What was the issue?

@Zach_Kaplan I’m not entirely sure, but I’m assuming it had to do with the WCS origin being on the model. In the video (not sure why you can’t see it), I just made a block in Fusion 360 and offset the work origin by 1" X & Y to clear the “smart” clamp.
EDIT: I just noticed the video upload seems broken.
Any ideas why? It was working .

I say upload the video to YouTube, if you haven’t already, and link to it. More reliable.

@PerryWolf That was my plan when I noticed the video was not working. Been on vacation, so I’ll get to it when I get back to my machine.

@Zach_Kaplan, @Ts1, @PerryWolf