Cant get this to work

Hey ive been trying to get this Xcarve / Easel to work. I flashed my machine like it said to do in tutorial with:
Board: Arduino Duemilanove or Diecimila
Processor Atmega328P
I did it all right, when i went to try to connect with the Easel / Xcarve it will not connect. ive been playing with this for awhile now. im lost at what im not doing right. I also downloaded the drives for it and they are running forsure. the com port is open was open till trying to connect This machine is was a DYI from china. its decent i would think, got the E11A spindle and the 5500mh lazer with it. So far ive been stuck on what to do. Any thing suggested is worth a try. Thanks for reading and hope for some kinda answers. Cheers!

1 Like

How did you flash GRBL?
What board do you have? Was the firmware flash successful?

1 Like

i used Arduino like the tutorial says at

i believe i have the ATmega168

I have tried to use my hand controller and now doesnt work at all haha

the machine i have is the 3018 PRO im having a hard time thats forsure. how would i find out my exact board?
The firmware flash was successful

Post a pic…probably recognizable.

1 Like

Just Realized its a woodpecker 3.2A GRBL

What does this mean?

Just the version of that board.
Are you trying to connect through Easel…does the “Carve” button turn green?

no its just red lights

Do you have the USB cable connected?

yes i do

port is connected

Got any other programs open that might be connected to it?
Any blinking LEDs?

no theres nothing open connecting to it. double checked thru task manager. tired changing ports/com just to make sure

Try connecting through Arduino Serial Monitor. Change baud (in monitor) to 115200

1 Like

When i flashed it to the above comment, my hand control quit working also. so how would i know what board i have or setting to flash too? the odd thing is that it successfully completed flashing it. I opened up the standard lazergrbl and wouldnt connect either (of course its unplugged right now)

Okay so you were right actually. the com port was closed by something else. i tried another com port / usb slot and i was able to connect to Arduino Serial Monitor and set it to 115200…

Its still 3 red lights though

What should i do next?

Send a “?” through the serial monitor…anything come back?

Nope nothing comes back (no time stamps either)

Below are some settings that they are on (if that helps any)

Those settings don’t matter to connect…you’re just using the serial monitor as a basic way to connect.
When you click to open the monitor, does it say anything at the bottom of the IDE?
Can you see what’s on the chip on your board? ATMega168? Or 328?

If no errors or warnings, and you’re not getting a response, it sounds like you might need to reflash firmware.
I don’t think GRBL works on the older 168s, so it might be a heavily modified version or you selected the wrong board. Try UNO.
Don’t open Easel until you can connect through Arduino…you’ll know when you connect.
I gotta go to bed…good luck!

okay thanks for the help! ill deff keep trying
Some info i have found is that during installation the driver that was to install was CH340SER.exe and its running 0.9j grbl