Cant load easel driver newer than 0.3.2 on my Macbook Pro

I have seen other problems regarding this and some solutions but I am not a person who likes terminal on the mac. I can get easel driver 0.3.2 to work fine but as soon as I try to update to anything newer i get the dreaded “You need to download and install the easel driver” over and over. I saw another post regarding this being a typo within some of the programing and they fixed it through terminal but thats not me. Is there an official fix for this from inventables that I am just missing?

Just for info I am running a macbook pro with OS X 10.11.6 and using safari as my browser.

There are several post about this topic

This one worked for me:

If this doesn’t solve your problem try to search the forum.

Ok I found the answer and will pass it on to anyone else who may have this problem and it was in the post you referred to. I simply removed the easel directory in the system library before doing the 0.3.10 install and that cleared everything up. There must be something that doesn’t get replaced in that library with the new install that ends up confusing everything.