Can't pilot Xcarve from Aspire and can't import Aspire Gcode to Easel

Hello, just borrow an Xcarve (1998 with a Xcontroller).
I try to send a job directly from Aspire (direct machining using Xcarve Post processor supply with Aspire), but no way I can’t see the Xcarve.
I try to export the Gcode by adding Easel Post processor, but I got an error code when importing the Gcode to easel.

Can somebody be kind enough to explain how to send job to the Xcarve using my drag knife toolpath create inside Aspire?

Thanks for your help.

for starters.

  1. make sure you have post Prosser, easel driver.
  2. save your gcode someplace you can find it.
  3. Import your gcode into easel. you will not have a preview of project.

you might want to use this instead >>

OpenBuilds Software - FREE Software for CNC Control: OpenBuilds CONTROL and OpenBuilds CAM

1 Like

Vetric version 11 include pre-installed post processors , including one labeled “Xcarve” and that one for some reason is not the same as the one that you can download from the Inventables website, that one bears the name “easel”

You discovered part of the issue with the “X-Carve” post processor that’s pre-loaded into Version 11 Aspire. . . , Easel cannot send Arcs (these are represented by I and J codes as shown in your photo as Invalid Gcode)

IF you want to use Easel as the sender you need to click the “Vetric V-carve,Aspire,Cut2D” grey button at the bottom of your photo, and follow the instructions there to download the correct Easel post processor and place it into the correct directory for Aspire to access it. . .

The other option is to leave your setup as it is and use a gcode sender that does support the arcs that are in the file… .like OpenBuilds as @Ken4 Suggested.
(it is also my favorite gcode sender)

1 Like

Thanks, by the way I’m running V10.5.
Not sure to understand well the G2/G3 limitation. Is the Xcontroller the guilty (Xcontroller run an old GRBL) and it can’t read new Gcode like G2/G3? Or it is just a Gcode sender limitation. Otherway to say it, Is the problem on the machine side, or on the computer side?
To be honest, I will prefer to keep going with direct machining from Aspire, but I can’t get rid of “ALARM” state!


it is easel that does not support the G2/G3 the cnc is perfectly capable of running with them… (problem is computer software, not machine)

The VTransfer “alarm” should clear by pressing the “start homing sequence” button.

Thanks, I tried this, but seems the Z limit switch did not work. I just borrow this Xcarve and I don’t know why it is not working. I can’t even inpect the limit switch with easel as there are no limit switch in the machine inspector screen!

That screen shot indicates that easel is not connected to the cnc. If vtransfer is still connected then easel cannot connect.

That screen will populate fully once easel establishes connection to the cnc and you’ll be able to see the limit switch status

You should see all of this data once easel is connected to the cnc. …

Sorry, that was the case. All witch are working from easel inspector, but home switch is not working on Aspire, neither on Easel.

Sorry, but on my 3018 it was working straight ahead, I was not expecting so much trouble with an Xcarve.

5Th trial with Openbuild control:
What Post processor should be used with openbuild control? I tried the xcarve one and openbuild, but none of them managed the Z lift to make the blade turn smoothly. I used Aspire Dragknife gadget to create the toolpath, and such gadget do have a Z lift parameter at each corner.

That’s exactly what I’ve done, and it gives the G2/G3 error.

I’m a vectric user , I don’t have any issue with Easel or open build sender…

you must be doing something your machine just doesn’t understand

Thanks, Finally Vtransfer is working (unplug & plug again the USB port). Thanks for your help