Carve button does not turn green

About 95 percent of the time, the Carve Button will not turn green. I then have to turn off and on the X-controller or unplug the USB cable several times before it decides to finally turn green and let me continue.

I’m using the latest version of Windows. I’ve tried different USB cables. I’ve tried restarting the PC and refreshing the browser. I’ve tried uninstalling and reinstalling the Easel local app.

I can still get it to work eventually, but it takes a lot of extra time waiting for the software when I’m in production. (I almost aways have to turn off the x-controller to move pieces in and out or I would just leave it on.) Does anyone know what else I can try to get the button to turn green faster?

Thanks for any ideas!

A lot of time certain USB controllers can just be a pita. Have you tried to move the USB cable to a different controller or hub? On a PC this is certainly possible, if it’s a laptop it may not be. My suggestion would be to look into your USB controller drivers and update/reinstall them. That is usually a solution for most handshake problems.

1 Like

I have tried different ports but not a hub. I’ll give the drivers an update.

I think I’ll also buy a powered usb hub to see if that helps. Thanks!

I would hold off on the hub for now. I don’t think I really explained that well. Any hub you buy will go through the same USB controller that’s giving you trouble. I meant if you were using a hub, you might want to bypass, or switch to a different one. Sometimes USB hubs will be powered or unpowered, using their own 5v signal. Sometimes there are voltage regulation problems and it causes handshake issues.

If you’re plugged directly into the computer, definitely look into the USB controller drivers, you’ve already tried different cables so that would be the natural progression. I will tell you that over the years I have had some motherboards that just had USB controllers that were a pain to deal with.

Another thing you could do is check the USB connector pinout on the PCB to the X-controller. I doubt that would be an issue, but I have run into hardware that had cold solder joints on the USB headers causing issues, but we’re really going out on a limb now. I think the best bet would be to try the drivers, and then try a different PC simply to see if you have similar issues to diagnose if it’s the x-controller, or your PC.

edit: One thing I always do when troubleshooting USB, especially when I think it may be the USB port itself, is hold the USB cable at a different angle for about 30 seconds. Just apply pressure from different angles and hold it to see if the computer handshakes with the device. Good way to diagnose bad connections/cables.

1 Like

I have similar issues much of the time, so will keep an eye on this thread. It has gotten better since I found an instance of Chrome running in the background and shut that down.

I’ve tried all six different usb ports on the PC, so I don’t think it’s hardware connection. I don’t have any other applications running or needless browser tabs open. I have not tried using a different browser - which I will try next.

do you have another PC or laptop you can try first? Need to figure out if it is your PC or if it is the X-controller.

OK, I can bring my MacBook to the shop and try that. But I’m not sure if we can blame the PC since any other usb device I plug in is recognized - and works - right away. I’d hate to have to buy a new PC just for the sake of the x-controller. But if I’m the only one having this problem then it must be my PC.

I wouldn’t worry that much, just the easiest way to start. You also might want to try and reinstall the easel drivers as well. I’ve had it a little finicky in the past.

might be the USB port.

My cnc machine did the same initially but it was defaulting to the wrong com port. Once I figured that out works every time now

Thanks Mike. How do I assign a different com port? This is on the PC not the controller, right?


Have a look in the device manager and see when you plug the usb connection in what port it shows in and then check in the machines settings what port it is set up to as a default.

I’m not sure how to check that on an x carve as yet as I still need to check behind a few hundred more sofas to find the money :joy: