Carves are stalling after x-controller upgrade

I’m having trouble today with some of my carves stopping at random points after I upgraded to the x-controller. It will just stop randomly and the progress bar will stop as well. Sometimes at the same spot if I stop the carve and restart from the beginning.

I’ve never had this happen before upgrading to the x-controller so that makes me think that is the source of the problem. Ive checked all connections and changed my USB cable out with the original cable with no luck. I’m just running the x-controller setup like the original setup for now. I haven’t upgraded to separate y axis wires or any z probe, etc.

Anyone else having this trouble? Most of the times I can quit the job and the spindle will return to zero zero but twice it wouldn’t return and locked up in position.


This makes me a little nervous. I have the x-controller but haven’t installed it yet. I have a couple of important carves coming up that I can’t take chances on installing and something not working. It will be interesting to hear of the responses you get.
I plan on ‘making the move’ in about a week after I get these projects done and plan on Option 2 with the rewiring. I’ll report on how it goes.

UPDATE: Wrapped up the projects and installed the X-Controller this morning. Have run numerous projects today and has been performing flawlessly right out of the box.

I did about an hour carve today and everything went fine.

One thing I did notice was my z calibration was off. I didn’t recalibrate after installing the x-controller, it seemed to work fine. But I was carving thin stuff and didn’t notice the z axis being off. I was carving 3/4" stuff today and realized the z axis was only carving about 2/3 of the correct depth.

I recalibrated the machine and all seems correct now. Maybe that was my original problem as well. I didn’t see that in the instructions, but I could have easily missed it.

I have a few more projects the next couple of days so I’ll see if the stalling still occurs.

Out of curiosity did you have a second window with easel running? I accidentally had easel open in another tab one time and I had the exact same issue that your describing. I don’t have an x-controller but its worth a shot.

I did one time that it happened. I had a 2nd one open because I copied part of what didn’t get carved into a new project and forgot to close the 1st one.

I closed the one project and attempted it again and it stalled in the same place. Seems to be fine since I’ve reset and recalibrated the machine.

I have the same problem of stalling, often in the same places, but I’m not using the x-controller. It’s driving me mental.
I’ve swapped USB cables for originals, and tried shielded cables, isolated the x-carve to its own circuit etc.

Sometimes it will run the file perfectly, then it will stall for the next few hours trying to run it again. UGS sometimes locks up, but not always.

I can’t work it out

That is maddening. It seems to be more of an easel sending the g-code issue since the progress bar locks up as well.

It is weird that it has started for me since the x-controller install. I have really crappy DSL and once it happened around the time I lost Internet, but I don’t think that is the issue.

I had a similar issue using the Arduino & Grbl shield. I was using Firefox Browser and my projects were stalling mid project. I switched to using Internet Explorer and have not had an issue since.

I had this problem pop up again. It was on a g-code import and I kept thinking it was in the code. Code was fine after further inspection.

I started messing with the x-controller again and I never liked the USB connection on the controller side. So I decided to put some side tension on the cable and go again. That seemed to fix the problem. I think when the spindle was rapiding to its starting location it was losing comm and then stalling.

More cutting will determine if this the fix, but it works for now.

Just upgraded to X-Controller. Mine is stalling shortly into every job. It runs fine if the spindle is off. My guess it that electrical noise from the spindle is killing the USB link. But this setup worked fine with the gShield!

Anyone else having this issue?

Ok, bypassing the little USB pigtail inside the case totally solves this problem. I guess the ground connection is broken somewhere in that cable.

1 Like


I haven’t cut much since I posted but I haven’t had the issue since. I sounds like we have the exact same problem. I did also move my dust collector to a different circuit. It stalled once when I turned on my DC after a carve had already started.

Have you tried a different USB cord or doing what I did and putting sideways pressure on the connection? I’m gonna carve some tomorrow so I’ll see if it reoccurs.

That makes sense Matt. I never liked the connection feel anyway. I may just bypass mine or find an upgraded part.

Okay, I bent out the grounding tabs inside the USB receptacle on the front panel of X-Controller so that they would press more firmly on the ground shell of the USB D-connector. This solves the problem of motor noise killing the USB link. … although its not a very satisfying solution. Time will tell if I need to find a better USB pigtail.

Well… bending out the ground tabs seemed to help for a few days, but after more jobs stalled, I took the front panel off again and ran the laptop USB cable directly to the X-Controller circuit board. Works perfectly again, no stalling. I’m hoping Inventables will acknowledge this problem and recommend a replacement for the interior X-Controller USB cable.

1 Like

What cable did u use to connect directly to the board. Different connector on the board

I think it is called a Type-B Mini USB connector. It was quite common a few years ago. I just had one laying around. You can probably pick one up at any store with an electronics department.

I haven’t decided what to do long term yet. Sort of hoping that Inventables will offer us a fix.