Carves not lined up

Sorry if this has already been covered but I could not find it. I am new to X Carve and have just been doing basic stuff. But now I’m trying some more complex stuff and it’s not lining up.

I downloaded the cribbage board plan in the projects section and tried to carve. I carved the holes first which I messed up on my board but anyway then I changed the bit re-probed the bit and used the same x and y as previous and the pics show my results.

Welcome to the community!

The misalignment seem to be inconsistant indicating that the machine lost steps along the way.
If the misalignment is consistent between tool change one possibility is that the machine position was shifted during tool change.

The Xcarve is an open-loop machine meaning that position is always assumed - if its shifted or was unable to perform some step commands the controller is unaware of that.

So basically what you are saying is that the X Y manually got moved when I changed the bit so it list position???

No, not really. If XY got moved during tool change the carve/2nd stage would be equally offset. This dont seem to be the case here though its hard to say for sure.
It is certainly possible to move it unintentionally during tool changes, atleast with the default $1=10 value (should be =255) and torque reduction setting of the Xcontroller which = ON. Inside the Xcontroller there are three red switchblocks, set switch #4 on all three to OFF.

You say:

Messed up in what way exactly?
Have you retried the project?

Hi also new to the XCarve and I know I’m having a problem with moving the carriage during bit changes. What is this (=255) you speak of? Is there something I need to change to stop this from happening. I have tried locking motors and that seems to do nothing. Have also tried clamping both sides of x and y rails by the wheels to prevent this but apparently I am wicked clumsy!
Sorry for piggy backing but didn’t want to start a whole new topic when there was clearly someone here that could help. Thank you in advance.

  • GRBL parameter $1 govern the time (in milliseconds) the stepper have full power before it go to reduced current mode to preserve power/decrease heat build-up on the steppers.
    For most this is a non-issue.
  • Motors locked equal $1= Full power during lock, no reduced current mode
  • If $1 equal anywhere from 1-254 this is time in ms, if $1 equal 255 that means “never idle”.

So with $1=255 the steppers will never be set to “reduced current mode” and you have maximum protection against shifting position during tool changes etc.

Going to retry today, I flipped the switch on all dip switches and we will see what happens

So I did a second carve and from the two cuts I feel that it is working the way it should now. Thank you for your help.

Now I have a second dilemma, when I went to do my third cut, the v carve I somehow lost connection with the x controller. When it reconnected it asked if I wanted to home or unlock without homing. I did unlock without homing and the v carve started in the middle of the board. Any way around that issue???

If you homed ($H) prior to the start of the carve you could simply re-home and confirm “Use previous work zero”. If you did not home prior or have any other fixed reference point the work zero is lost.

When you Unlock without homing you simply clear the alarm state and machine zero is now wherever the machine is at reset. Homing determine machine zero and sync machine space to model space.