Carvey cuts off path and too deep

Hi, we’re having a few issues with our Carvey that we just got a few months back. We haven’t used it very often (still in the learning process), so I don’t think these are due to overuse or parts wearing out.

The most dramatic problem is that the machine is cutting wildly off path when using the recommended settings for cutting 3/4" hard maple with the 1/8" straight bit. The recommended settings from Easel are 72 ipm feed rate, 9 ipm plunge rate, and 0.03 depth per pass. After this failed multiple times, I tried using the 1/8" spiral upcut bit (same file and material) and noticed Easel recommends a much slower feed rate (24 ipm) in this case. That cut completed successfully. Therefore, I also tried going back to the 1/8" straight bit but using a slower feed rate; at 48 ipm, it still went way off path, but 24 ipm worked. Here’s a picture of what happened with the recommended settings:

I had previously cut 3/4" maple with the 1/8" straight bit without incident. However, this was 2 driver updates ago. Could the recommended settings in Easel have changed for this combo or something been set differently in the driver? I read another post with a similar problem, but I don’t think there is debris blocking the rails, since it can cut, just much slower.

Another issue is with the depth of cut. After doing some tests, it seems the first plunge goes into the material about twice as deep as the nominal depth per pass (or about 0.03"). I can get the right depth by subtracting this amount and telling Easel to cut that far. Or, if I’m trying to go through the piece entirely, I have had some luck telling Easel that the material is about that much thinner. Otherwise, it starts cutting into the waste board pretty far (and I think wore a bit out super fast because of the difference in material). So I can kind of work around this, but other people will also be using the machine as we’re trying to teach classes, so it would be better if it would simply cut as it should so I don’t have to warn every new user about it’s quirks.

We’re also having some issues with dimensional accuracy on fill cuts and seemingly “overshooting” corners (see picture below), but I haven’t had time to test that with a variety of materials and bits, so I’m trying to solve these other problems first!

Thank you for your help!

1 Like

I’ve been having this problem with my X-Carve. I found that the edge of my Z-Probe is thicker than the rest. Like you, I’ve just been taking steps to work around this.

This indicate that the sideway forces onto the bit it pushing the spindle “away”. There is a deacceleration/acceleration at corners = the bit spend more time here => cut more.
If you did a test cut with much less aggressive depth per pass/feed rate this should reduce/disappear.

(OP here, didn’t notice I was signed in as someone else when I posted!) That makes sense for the last issue, and I did make the square cut with the original settings. I guess I don’t understand why the recommended settings for the machine are so far off. This leaves me wondering if something is wrong with our Carvey and it isn’t performing as it should OR the recommended feed rate in Easel is incorrect.

Thanks for your response, Phil. I agree it seems way too fast. This is what I see when I look at Easel:

So, that’s really odd. Do you have the 1/8" straight bit selected or the spiral upcut? Why would we see different values? If I change the machine to the X-carve, it tells me 28 ipm with the same material and bit.

I wanted to add a conclusion to this post, since we’ve pretty much solved the problems we were having. Shout out to John Hayes, a member of the Inventables support team who was super helpful and patient as we exchanged emails getting it all ironed out.

The recommended feeds & speeds were updated in Easel since my earlier posts, and some of those really aggressive values have been brought back down. In the interim, I found the recommended chiploads for a few materials in this thread and used that to calculate appropriate values (based on the Carvey’s apparently consistent 12000 rpm).

After much testing and measuring of cut depths, John added a z offset to our machine. This ended up overcorrecting (guessing there was a minor update in Easel which was not apparent), so we eventually removed that but now have correct depths! Hooray for Inventables’ work behind the scenes.

I’ve now successfully cut a variety of materials with several different bits and am super excited to do more projects. :slight_smile:


I’m not being funny but you even “test” as the bit breaks…

@StarHen How did he apply an offset to your machine?

He asked us to do some test cuts to a particular depth, then report the difference between the intended depth and actual depth. He also needed the serial number for our machine. Since Easel is web-based, I guess they can send selective commands/apply selective code based on the serial number? Or possibly magic. :wink:

@StarHen That’s interesting. If you export the gcode from Easel, line #5 on mine says:
G10 L20 P1 X17 Y-12.25 Z12.7
After the Carvey probes the smart clamp, it sets the work position to 12.7mm above the surface of your material. Is yours different? That is coming from Easel. Maybe they adjusted your steps per/mm in the firmware? I would think that all Carveys (Carvies?) would have the same value there, though. Can you share your $102 value?

We did a quick video to show how to fix this issue: