Carving keeps stopping (Resolved)

Very frustrating problem. I have an Xcarve ( 2018) (1000mm, GRBL 1.1f) , I am using Fusion 360 to create the gcode and using Easel to send it. It doesn’t happen all the time but part way through the carve ( about 45%) the xcarve just stops and Easel says it is finished. It happened 3 times in a row today( not in the same spot) on 30 minute carve.

So far I have tried;

  • PC set to never sleep
  • active 5M USB extension cable
  • USB connector cable with ferrite beads
    -USB cable secured
  • good home WIFI signal

I have home switches but no limit switches. It is a good PC running Windows 10 and I don’t do anything else on the PC while it is carving. The only other USB devices running are backup harddrives.

I’ve run out of things to try. My only other option is to switch from Easel and try UGS.

Any suggestions? Also is there a log anywhere that may give me a clue as to why it is stopping.

Thanks,
Christopher

Further to my previous post. I re-loaded the firmware and rebooted the pc and it managed to make it to 75%.

When it stopped ( 4th time ) I immediately went to machine inspector. The status was in Alarm and the machine position was 0,0,0 (???) Does that tell anyone anything? You would normally get that if the power was reset. I am pretty sure my AC power is good.

If the USB connection drop out Machine Position will reset to 0,0,0

Try a powered usb hub.

Is that the same as an Active USB extension cable?

Yes and no.

The USB hub actually acts like a device so it’s kind of like having a termination point and then a new connection.

The problem with active cables can be that you’ve still got degradation over the cable and sometimes even an active cable can’t overcome the cable losses.

You’ve done a lot of investigating and made some good moves already.

I agree with Phil. There is a good thread labeled “RESOLVED” just a bit further down in the forums with someone having the exact same issue and it was their vacuum.

Try changing up some of the basics one at a time, like run it without the vacuum if you normally do. Plug it into a different outlet. A different USB port on your laptop. Etc.

I’ve already tried different USB ports. I am pretty sure its not an AC issue, the ground is ok and we have good power in our neighbourhood. It has failed with the vacuum off. The vacuum is on a different circuit.

I’ll try temporarily moving my PC and using the shortest USB cord that I have. I could also 'borrow ’ my wife’s laptop when she is at work and see if it fails the same.
Thanks.

Try running the carve with Dewalt OFF and without bit nor material.
Which speed setting have you used BTW?

I had a similar issue for months, after reading a lot here I did the following:

  1. new wiring with double shielded wires
  2. grounded the shielding of the wires
  3. removed the power wire of DeWalt from drag chain
  4. updated Windows drivers
  5. externally powered USB hub between XController and PC
  6. switch energy safe options to full power (=do not switch anything off)
  7. switch USB energy safe mode to disabled (be careful here. It’s a separate option in the device manager for the USB root hub and not part of the general energy saving options)
  8. removed the USB bulkhead from the XController und connected directly to the board using a mini USB cable
  9. manually changed the baud rate of used COM port in Windows to 115xxx (was 9xxx)

One of the last three points did the trick for me. I would suggest testing the quick wins (4, 5, 7, 8, 9) first, since they are quickly done and cheap.

5 Likes

Wow, thanks to Dominik and everyone for all the great suggestions.

I temporarily moved my pc close to the Xcarve then using a short USB cable I ran the same cut ( which had previously failed 4 times) and it worked ! But of course being a pessimist, I reconnected the long active cable and ran it again exactly the same except for no bit and that also worked. Don’t you just love intermittent problems. :persevere:So I’ll just have to wait till it fails again.

One setting that I have changed, after the successful carve so I can’t prove it was the problem, is the COM port number ( from 6 to 2 ) and the speed (from 9600 to 115200). To do this, go to the Device Manager under Ports - USB Serial Port. Change under PORT settings. Your controller must be connected in order to see this.

Also in Device Manger if you change the View to ‘Devices by Container’ you can see the X-controller listed with the USB Serial Converter and the USB serial port . My drivers were all up to date and the power management settings were correct so no help there for me.

I’ll probably order a powered USB hub from Amazon today as it will eliminate the cable issue completely.

1 Like

I stick to ‘1’ as this is what is recommended by Inventables. The Dewalt router is designed as a handheld trim router not for a CNC so a faster speed may not be helpful. I am mainly making cottage signs out of cedar and pine so I as long as I get good sized chips I keep the feedrate fairly conservative.

1 Like

I mentioned it since many seem to miss that suggestion.
High RPM = more RF noise from the Dewalt (or any brushed motor for that matter)
In case RF was your issue :slight_smile:

2 Likes

Individual applications change the speed. The Windows setting is just the default setting.

1 Like

Since I had a similar problem I can tell you getting it start with 9600 in Windows setttings is no problem. I’m using Chillipeppr and my understanding was, that it changes the Baud rate itself.
My assumption is, that something between and can go wrong under certain circumstances, but to be honest my motivation to investigate further was exactly zero after having months of stopping carves.

I agree with Phil and Drew. You have a problem with static in your vacuum pipe. You need to purchase a new vacuum pipe that is electrically conductive (the standard plastic pipe is no good whatsoever) and then put a metal strap around it and take a wire to earth. I spent months and a lot of money chasing the very same problem. The issue happened most when I was cutting MDF. Now that I have replaced the pipe and earthed it I’ve not had the problem again.

Thanks for the suggestion but the problem pre-dates the connection of my dust collector. Also I have an Inventables one which has the conductive plastic hose.

I haven’t had the problem (fingers crossed) for a while but then I haven’t done any long carves.

Using Chrome on the computer?

No . Windows 10 & Microsoft Edge 41.16299.402.0

Use chrome. I have windows 10 and use chrome. Never had a problem

1 Like